2018 Mac with Krita 4.4.5 is s-l-o-w

I have a friend to whom I introduced to Krita and when she uses it, her strokes appear so slow. I’ll have to get the info on what model it is if you need that.

Anyway, is there a way to get Krita to work more smoothly on her MacBook?

I have seen this particular post: https://krita-artists.org/t/disabling-canvas-graphics-acceleration-improved-performance-under-macos-a-lot/11711

But, not having a Mac myself, I don’t know where to tell my friend where to find that particular setting.

(Her computer is a 2018 MacBook)

You can find it in the settings of Krita, under “Settings” >> “Configure Krita” >> “Display”, only there is a big BUT. :upside_down_face: That BUT is, there is not supposed to be a menu called “Settings” under Mac OS X! :upside_down_face:
I may be wrong, but if I remember correctly you have to click on the apple icon to get to the settings in Mac OS X, there everything is the same as in Linux or Windows - I don’t use Mac OS X either. :thinking:


Thanks, I’ll have her try that next time.

For me i have no advantage to brush performance if I disable the graphics acceleration. The graphics accceleration is used to perform better canvas pan, rotation and zoom as a sample, and a big disadvantage is that this is lagging heavily if you disable it. Without graphics acceleration i wouldn’t work in krita, it is like working with a applied handbrake, if you move, rotate or pan the canvas often.

But of couse worth of trying, you see the performance immediataly for brushes and canvas rotation.
The setting is normally in the menu bar where all menus are: Krita, Preferences, Display, Canvas Acceleration. The macOS settings is the wrong place for it. The menu bar in macOS looks practically the same as in windows, except that it is not at the top of the App, but at the top of the screen.

It looks like the slow brush is from the weak cpu of the laptop. If i remember correct, kritas brush engine or maybe only the smudge brush is single core, the maximum power of one core is important. (i thought it is like this)

1 Like

Thank you @anon71590212, that sounds logical.

I also forgot to mention that we were running Zoom and I had her share her screen so that I could see what she was doing (she’s not very aquatinted with it so I was guiding her.)

Perhaps her Mac’s CPU couldn’t handle that then?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.