A part of image disappeared unexpectedly after drawing a line!


Now that I draw a line by the mouse.

What`s wrong with it?

My system and hardware : win10, 5900x, RT 6900xt

I tried to close canvas acceleration, but it`s no use.

Have you accidentally turned eraser mode on, say, by pressing “e”?

No, you can see that the line I would to draw had been drawn.

Which version number of krita are you using?
Are all the lines on the same layer?
Are they vector or paint layer lines?
If you turn the layer visibility off then on, do the lines come back?
If you turn off visibility of all layers then turn them all on again?
If you Save the image, Close it and then Open it again, do the lines come back?

  1. both 4.4.8 and 5.0.0 beta.
  2. yes.
  3. paint layer.
  4. This error doesn`t always occur, it`s fine now, so I can`t test temporarily.
  5. as above.
  6. I had tried, it hadn`t come back.

I’ve only seen this sort of thing happen with vectors before and quite rarely nowadays.

It looks like a tall thin rectangular area has been deleted.
As you say, if it’s fine now, you can’t do further tests.

All you can do is keep a lookout for it happening again and try to determine if anything particular/special/different was done just before the lines went missing.