Android app, Clone brush engine: Cannot select source point with Ctrl Click

When doing a ctrl click with the Android app with a Clone Brush engine, the source is not picked. All that happens is that a color is picked, as if I was using the color picker tool.

ctrl click as in ctrl + mouse click or ctrl + touch/stylus?

In the first case (ctrl + mouse), if you built Krita against master or used my builds, Qt would convert mouse events to touch events (!!). This has been fixed in krita/4.2 branch :slight_smile:

If it is the second case, I am not sure if the brush engine recognizes this key combination. It might work on touch/tablet synthesized devices. But on Android, they are not synthesized :slight_smile:

I am referring to both mouse clicks and pen clicks.

I am using a nightly build from sometime before the “RESOURCE REWRITE” text start popping up in recent ones because I found it relatively more stable. I take it more recent nightly builds have it fixed then?

Yes! I’ll upload them all, tonight :slight_smile:

1 Like

Thanks, looking forward to it! :smile:

I tried the clone tool in the build you uploaded today and unfortunately the issue still persists:

Can you please test this?

Unfortunately, I don’t have the required dongle, to test it myself :frowning:

I am happy to report that both the Samsung S-Pen and bluetooth mice work with the clone tool in this build! Yay! You can see the behavior in my recorded video. Behavior without a mouse cursor is me using the S-Pen. Behavior showing a mouse cursor is me using a bluetooth mouse.

Here are my observations:

Finger: You can paint with the Finger when using Clone, but you cannot Ctrl + Finger Click to set a source. This requires an S-Pen or bluemooth mouse.

Samsung S-Pen: Tool works perfectly! :smiley: Can set a source point with a pen click now!

Bluetooth Mouse: Tool works, but sorta weird at first. When setting a source point with the mouse, the point is set, but at the same time, the source point also becomes “stuck” to where your mouse cursor is currently pointing, preventing you from cloning in an offset position. To “fix” this, the user does the following: 1) check “source point reset before a new stroke” in brush settings 2) make a brush stroke on the canvas. at this point, the source becomes unstuck and reverts to your originally selected point 3) uncheck “source point reset before a new stroke” 4) resume normal behavior.

Thanks for getting back to me with this build! :slight_smile: I appreciate your fix.


Thank you for testing! Good to know that it worked :smiley: