"block tilt" brush doesn't work/appear

Type of device* : laptop and wacom tablet (CTH 690)
Brand and version of the device: asus vivobook S
System** : windows 10 version 20H2 (os build: 19042.1110)
i’m also using the most recent release of krita and wacom tablet drivers

Description of the issue (you can include screenshots):

basically the same as the title, the “block_tilt” brush doesn’t appear at all when i try to draw with it, and yknow how when you hover over the canvas with a brush, it shows that brushes outline? it doesnt do that with the block tilt brush.

the preview of the block tilt brush doesn’t appear either in the brush settings



and when i try to draw on the scratchpad with it, it also doesn’t appear.

i first checked if i was using a white color, or having the brush be on eraser mode, or having something selected on my canvas, etc. etc. none of it worked.
then i restarted krita, then my laptop, then installed the newest version for both krita and my tablet drivers, still didn’t work.
i looked up the issue online, and this one post said it had to do with the tablet not being able to support tilt, but i was able to draw with every other “tilt” brush except for block tilt.

if anyone has any idea how to fix this, it would be a great help, thank you!

:slight_smile: Hello and welcome to the forum @kanra!

By reinstalling Krita, you won’t change any of Krita’s settings or resources, such as brushes, because the files for them are not in the installation folder.
If you don’t have any self created custom resources, like brush presets, you could try deleting the resource folder completely to rebuild them afterwards.
That is, quit Krita and then delete the whole folder named “krita” in “c:\Users\YOUR WINDOWS USERNAME\AppData\Roaming” where you have to replace “YOUR WINDOWS USERNAME” with your Windows username. Then restart Krita and during this restart Krita will completely recreate the resources, but only those that Krita brings by itself, brushes, brush tips et cetera created by you will be deleted this way. To save them, you have to copy them out of the folder “paintoppresets” and save them somewhere else. You can then either copy them back there manually or import them into Krita using the resource manager.

Does anyone else have an idea what @kanra could do?

Michelist

Edit: Fixed a formatting error that led to a misrepresentation. Sorry!

With the 4.4.5 appimage and the latest 5.0.0 nightly, I don’t see the ‘Block tilt’ or ‘Textured tilt’ brush presets anywhere.
So, I’m not sure what’s happening there.

The two presets mentioned by @kanra are from the “Krita_3_Default_Resources.bundle”, and if @kanra has nevertheless correctly transposed my posting, which was first messed up because of the text formatting error, then he should have the presets available again now.

Michelist

I had the Krita_3_Default_Resources bundle disabled :unamused:

My stylus doesn’t have a tilt output so it looks like it’s providing a Tilt Elevation of zero degrees which would give a Size of 0%.
Hence no painting and a brush cursor size of zero.

If I adjust the 0 degrees point to give 10% size on the transfer curve then I see an outline and it paints with a small size.

I suspect that the Wacom CTH-690 doesn’t have a tilt signal.

The preview in the brush editor shows pressure increase effects on the stroke of the brush.
For any brush preset, if I disable size with pressure variation and enable a tilt elevation input with the same ‘top left to bottom right’ transfer curve, the preview shows nothing.

This is probably technically correct for a stylus with no tilt sensitivity and it shows what I get, which is nothing.

Someone who has a tablet with a tilt output would be able to have a more relevant look at this.

My tablet also doesn’t have a tilt function, what i do as a workaround is change tilt parameters in the brush settings for drawing angle.

If your pen has no tilt even the brushes with tilt that seem to work are actually not working as intended.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.