brush sensitivity stuttering with UGEE M708 v1

Type of device* : Drawing tablet
Brand and version of the device: UGEE M708 v1 with 2019 PenTablet driver
System** : macOS Big Sur 11.3, Krita 4.4.3


So this is sort of a weird one. Whenever I start up Krita, the first stroke with my pen/tablet is fine, and the pressure sensitivity works as it should. It continues to work until I lift the pen above the hover range of the tablet; once I do that and bring it back to the tablet, the pressure sensitivity stutters (screenshot below), though it still “works.” It does this with all pressure-sensitive brushes. I tested the tablet with other drawing programs and it works fine there, and the pressure readings on the tablet settings menu does not stutter, so I’m fairly certain this is an issue with one of my settings but I just can’t figure out which one. Krita has plenty of allocated memory and doesn’t lag otherwise, and drawing with the mouse or non-pressure sensitive brushes does not do this.

Settings I’ve tried that didn’t work:

  • FPS while painting (no change)
  • Memory allocation (no change)
  • Graphics acceleration (turning it off made the brush go crazy; changing the scaling mode didn’t do anything)
  • Mouse events workaround (no change)
  • Autosave timer (no change)

Try re-installing your tablet drivers & also making sure you don’t have two tablet drivers installed.

Didn’t work & I only have 1 driver installed, though I did find that unplugging the tablet & plugging it back in has the same effect on the pen as restarting Krita (the first stroke is normal and stutters after being lifted above the hover distance).

Also check out: H1161 - Brush Freezing

With Mac computers, you usually have problems with the security and privacy. Check your privacy and go to accessibility. I used to have a mac a long time ago, and always my problems started there. I know I am not really helping here, but that’s maybe something to investigate. Best of luck.

Well, thanks both of you for trying, haha. I did a complete re-install of the tablet drivers, restored all Krita settings to default, downgraded to Krita 4.3 (a version that I know works with this tablet on a Windows 10 computer), and made sure Krita (and the driver) had all the necessary permissions in all of my security settings – nothing. I tried it with a couple other programs and it didn’t seem to do it with Corel, but does to it with Autodesk Sketchbook, so I guess it’s most likely a driver problem. But it’s minimal enough that Autodesk is usable, while Krita isn’t.

1 Like

I saw you have the 2019 version of the driver, and your tablet is the V1 version. The manufacturer only supports driver for the V2 now right? Maybe trying a different driver helps?
If you didn’t already found this, then this post here may help you.
I found this link with the 2017 driver version, also there is this Reedit thread with different drivers.
Lastly, I saw this video where someone has to install the Wacon drivers after installing the UGEE one on a Mac. Although it is a different tablet model and a older Mac version, maybe it is worth giving a try.
Best luck to you