Can't export record time lapse krita, any solution of this problem?

I try to change the directory to save the export, then the krita is freezing, shud do force stop to reopen the project again

Hi.
Does your defined recording directory showing the recorded images ?

Hello and welcome to the forum :slight_smile:

Are you using the snap package?

Can you try downloading the appimage, give it execution permissions then run it to see if that fixes the problem? :.
https://download.kde.org/stable/krita/5.1.1/krita-5.1.1-x86_64.appimage

That would not use the same config files and resources as the snap package and so it would be like a fresh start and you’d need to point to ffmpeg again.

Also, did you get ffmpeg from the recommended place:
https://johnvansickle.com/ffmpeg/releases/ffmpeg-release-amd64-static.tar.xz

yes the image is showing up

Ah, @AhabGreybeard is here :smile: !
I was thinking about the ffmpeg version,but he already has provided much better and specific direction than me !
I had faced an issue with timelapse video export a month ago,but updating to ffmepeg n4.4.2 version just solved my problem.
I believe his suggestion will solve your problem.

any link file download for ubuntu ?

ffmpeg i use bionic beaver
is here 7:3.4.11-0ubuntu0.1 : ffmpeg package : Ubuntu
but the latest version is 3.4.11 :frowning:

The one from the johnvansickle site is an independent executable, not tied to any particular distribution, in the same way that the appimage is not tied to any particular distribution.
It’s recommended and it works.

Note: The ffmpeg download seems to be ‘double wrapped’ so after you extract it then you get another archive that needs to be extracted again. I’ve no idea why that is done, unless it’s to keep it fresh inside the package.

I guess maybe because mine was windows version ?!
I am not too sure about if ubuntu and windows use different versions of ffmeg !
Probably this is going to be a very stupid question…
but have you successfully managed to export timelapses from krita before or this is your initial tryout ?

@ari The Windows and Linux packages are different builds (obviously) but the recommended ones are at the latest formal relaase state which is version 5.1.1.
(By strange coincidence, the same as the latest krita formal relase version.)

@opal_flo The Bionic Beaver package seems to be frozen at 3.4.11 but version 5.1.1 is available for Kinetic Kudu.
The link I gave will provide version 5.1.1 for all Linux distributions and has no external dependencies.

Okay.
I was not aware of that,because so far I have remained as a windows user only.
but probably in future,it may change.
In that case,your inputs will be super helpful :slight_smile: .

Oops,sorry @AhabGreybeard :stuck_out_tongue: ! Totally missed the point of ffmpeg 5.5.1 and Krita 5.5.1 version.
Mixed it with linux and windows version !
Stupid me :stuck_out_tongue: !

@ari Haven’t, this my first try recording timelapse, the image is already exported so many in the folder snap, but i don’t know how about the mp4 and that popup error :face_holding_back_tears:

@AhabGreybeard well, it took me some time to understand how to use the link you provided as i new user for ubuntu tho, thanks for giving me an answer

If you have any additional problems with this, provide information here then I or any other Linux user will be happy to give help and advice.

Make the journey :slight_smile:

You can try checking tthese videos.
Just to check if you are skipping any small,but important step.

I hope you will find some positive solutions.

1 Like

Couple of years back I had tried Ubuntu studio .
Later on discontinued after I was unable to use some of my favourite windows only sofware.
But recently got aware about Wine,so in near future I want to give it a try again :slight_smile: !

1 Like

Alr try krita 5.1.1 and ffmpeg from that link (it’s works! i can record).
But :,) why the results of the export recording of krita’s timelapse, only one image. When i play the video, the process is not recorded. I already record from the frist make project tho…
The timelapse img is here


But when i look the result of mp4, nothing timelapse recorded :,

I’ve only ‘played’ with the Recorder so I don’t know much about it.
If the timelapse folder has the correct sequence of images in it then it may be something to do with the parameters that have been entered for the rendering process.

Can you Render an animation out to .mp4 with no problems?
If you don’t have an animation, here is a simple ‘technical test’ animation:
TestAnim-0-9-solid.kra

If you open that in krita, you can play it to check it, then File → Render Animation:

Your FFMpeg and Video Location settings will need to be suitable for your own computer, obviously.
I’m still on ffmpeg 4.4.1 so I suppose I should update it, one day.

I’ve just updated my ffmpeg to 5.1.1 and have no problem with Rendering an animation or using the Recorder docker:

I am not absolutely sure.
But it feels like your timelapse output came out okay.
There is only a long pause at the beginning,was it intentional ?
I mean,have you put any new custom value in options available in “export timelapse” docker ?


yes, here is it rendering animation the result TestAnim

is the location of folder ffmpeg & the video must in one folder?