Canvas Graphics Acceleration options

Hi

From another topic, I got a comment concerning the scaling mode and filtering options.

I’m creating a new topic because other post is not the right place for my question, as problem is different than question asked in other post.

For what I understand, the scaling mode is applied on zoomed canvas rendering, not on image pixels.

Is it right?
Or I didn’t understood the option? :thinking:

Another thing is, the first screenshot provided is what I have with Canvas Graphics Acceleration activated, with scaled mode set to High Quality Filtering

If I deactivate the Canvas Graphics Acceleration, now zooming/rotating canvas is slow, but antialiasing is nicer than one made by Graphic Card:

Is it normal?
I mean, that the same for everyone or it’s something related to my configuration?

Configuration details
Krita

 Version: 4.4.2
 Languages: en_GB, en, fr, fr_FR, fr
 Hidpi: true

Qt

  Version (compiled): 5.12.9
  Version (loaded): 5.12.9

OS Information

  Build ABI: x86_64-little_endian-lp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: linux
  Kernel Version: 4.19.0-14-amd64
  Pretty Productname: Debian GNU/Linux 10 (buster)
  Product Type: debian
  Product Version: 10
  Desktop: KDE

OpenGL Info
 
  Vendor:  "NVIDIA Corporation" 
  Renderer:  "GeForce GTX 1060 3GB/PCIe/SSE2" 
  Version:  "4.6.0 NVIDIA 418.181.07" 
  Shading language:  "4.60 NVIDIA" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:    QSurfaceFormat(version 4.6, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
     Version: 4.6
     Supports deprecated functions true 
     is OpenGL ES: false 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsOpenGLES: true 
  isQtPreferOpenGLES: false 

Hardware Information

  GPU Acceleration: auto
  Memory: 32133 Mb
  Number of Cores: 8
  Swap Location: /tmp

Current Settings

  Current Swap Location: /tmp
  Current Swap Location writable: true
  Undo Enabled: true
  Undo Stack Limit: 350
  Use OpenGL: true
  Use OpenGL Texture Buffer: true
  Use AMD Vectorization Workaround: false
  Canvas State: OPENGL_SUCCESS
  Autosave Interval: 60
  Use Backup Files: true
  Number of Backups Kept: 2
  Backup File Suffix: ~
  Backup Location: Same Folder as the File
  Backup Location writable: false
  Use Win8 Pointer Input: false
  Use RightMiddleTabletButton Workaround: false
  Levels of Detail Enabled: false
  Use Zip64: true


Display Information
Number of screens: 2
	Screen: 0
		Name: DP-2
		Depth: 24
		Scale: 1
		Resolution in pixels: 3840x2160
		Manufacturer: ViewSonic Corporation
		Model: VP2780 SERIES
		Refresh Rate: 59
	Screen: 1
		Name: HDMI-0
		Depth: 24
		Scale: 1
		Resolution in pixels: 1920x1080
		Manufacturer: Iiyama North America
		Model: PL2410HD-
		Refresh Rate: 60

Grum999

Can you please turn off the pixel grid and then make a new screenshot?

Tested all scaling modes:

  • Bilinear
  • Trilinear
  • High Quality

Same results for all: there’s no antialiasing :thinking:
image

Using Appimage 4.4.2 and Appimage 5.0.0-prealpha
(tested on other versions, 4.4.0, 4.2.8, 4.1.7: same results…)

I’ll do a test on my second computer later to check if I have the same problem.

Grum999

1 Like

I have no anti-aliasing when zooming in, either.
But when zooming out, I see a difference.
obraz nearest neighbour
max_zoom_out_oilpaintpng_high_quality high quality.
The cat is made of course by @Deevad, it’s from the filter test in Krita. Not sure what license but I guess either CC-0 or CC-BY since it’s used there.

1 Like

Yes

Did test on my laptop and same results.

So scaling mode is applied to zoom out, not zoom in.
Good to know the difference and the option behavior.

Thanks for answers :slight_smile:

Grum999

Yes it basically influences how mipmaps are sampled.
Mipmaps are scaled down versions of the original image map.

It may be possible to extend the “high quality” variant to do some antialiasing, from what I remember it is a pixel shader that aready does some manual sampling rather than letting the OpenGL driver/hardware do all the work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.