Color Picking slow when Advanced Color Selector is visible?

I just started painting again, at least a little.

I’m using the latest nightly build on Windows 10.

When I sample color from the Canvas, it isn’t instantly sampled, but rather takes about a second or so to “write the color to my ram”. It feels like that anyways.

When I hide the Advanced Color Selector however, sampling color from any other color picker or the painting itself works instantly again. I didn’t even deactivate the ACS, just opened another tab with another color selector.

Tested it with:

  • Small Color Selector
  • Pigment.O
  • Specific Color Selector
  • Swatches Palette

All of them work instantaneously.
Can somebody reproduce this, is it a bug?
So we could file it as such.

Thanks!

With the Dec 16 5.1.0-prealpha .zip package on Windows 10, I don’t see any lag when using the Advanced Colour Selector to select colours or when using the Ctrl colour picker to pick colours from the canvas. I used both mouse and stylus with no lag noticeable.
When I slide the picker cursor over a colour gradient, the ACS Hue indicator and SV location dot move instantly (or very quickly).

1 Like

I wonder what’s the matter with this. Can you tell me your specs? I think, don’t know for sure, that maybe it runs a bit faster on Intel CPUs, I have that feeling because my home PC has almost the same specs as the one at work, and at work the Intel machine is a tiny bit more flawless in some applications. Same GPU, both have the same SSDs.

Here I have an AMD Ryzen 1700, 16gb Ram and a NVidia 1060 with 6gb.

Hi

Do you have a 4K monitor?

If yes, if you reduce window size to a quarter of monitor surface, do you still have the problem?

Grum999

1 Like

Hi Grum, yes I have a 4k monitor. I think it is a bit faster that way, but it’s not gone completely. I also changed my resolution down to FullHD to test it. Also didn’t make much of a difference, but maybe a tiny little bit better.

I have old Intel Xeons with DDR2 RAM and a couple of 1280 x 1024 monitors.
It’s a slow old dog of a computer.

have you tried going to LUT management and turnning off “open Color IO” ?

3 Likes

Ok
Question was because I already encountered a bug with color selector on 4K monitor (has been fixed, but I prefer to be sure that’s not something like that)

On my side, if I activate it, I can see a delay in update of color selector…

Grum999

Marked as solution.

Thank you, it is now completely flawless it seems.

Is this OCIO calculating on the fly between the 8bit canvas and 32 bit raw, and turned off only using 8 bit to begin with? Just out of curiosity. :slight_smile:

1 Like

Thank you. I learned something today. After I turned off “open Color IO” I immediately saw the difference. Now then, any idea what the effect/downside of making this change would be?