Colour Picker stopt picking

Type of device (graphics tablet/display tablet/2-in-1 laptop/Android tablet): Wacom Intuos M
Brand and version of the device: Model 2019
System (Windows/Linux/Mac/Android, + version): Winstupid 10 Pro Build 19041

Description of the issue (you can include screenshots):

The colour picker doesn’t pick colours any more. It remains in the last manually selected colour.

I did some short test with ctrl and ctrl + alt. please see screenshot.

Thanks for any suggestions.

Update: Neither works the Picker tool §

your picking all from the same layer? not quite sure how to help
the picker has some options on it.

yes, all from the top layer. The top layer is the only one which has colour, the sketch layer has some pencil as usually. The sketch (side note: I imported the sketch by drag and drop and then I resized the sketch layer)

I cant locate my addon there to be forcefully pressing a color into the system. so I imagine it is not that.
if you open another session of krita it remains on the same behaviour?

something you can do it like consider this session like doomed and reopen your project on another session that is not tilted to yellow.

Closed everything and opened everything a few times which did not solve the problem at first. Then started with a complete new porject and there the picker worked as usual.

I then switched back to my eye-project and this time of a sudden the picker worked again.

This i misterious. I tried the scenario as it happen again but I couldn’t reproduce the failure.
Strange.

I am not a developer but when stuff like that happens it is ussually just best to export everything into another session.

those bugs ussually are hard to trace. if you can replicate it again just send that as a report if not, then it really just export import and reimport it again.

Donno if the file with the dammed session is of any use for them analyse or not though they would have to say.

But I am glad you were able to make it work again.

ey thanks a lot for your support :-). I don’t know, might be also the day, the star constelation or my damn stupid lenovo notebook :smile:.

Cheers
Jeremiah

I have been having the same problems with my color picker too.


This is what I got after trying to fix the issue myself. I really just want to finish my art peace but I can’t.
I use a windows 10 and i use the newest Krita

That error message indicates that you’re trying to add a selected colour to one of the standard palettes, the ‘Default’ palette in this case.

If you want to add colours to a palette, you need to create your own named palette.
(I believe there has been some change in this area but that looks like your problem at the moment.)

If you look in the Tool Options docker when the Colour Selector Tool is selected, there will be a checkbox: Add to palette with a palette choice drop down.
You need to disable/untick that checkbox to stop it from trying to update one of the stahdard palettes.

Are you sure that you’re using krita version 4.4.2?

1 Like

I am using 4.4.2 because I downloaded Krita recently. (in the last few weeks)
Thank you so much for helping me fix it. I really appreciate you taking the time to help me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.