Colouring images?

I am new to KRITA and i using version 4.4.3 and i am not being displayed with the colors i chose to fill instead its displaying me blue,pink,black only can please help me out

Can you post a full screen screenshot (.png) of the krita window that shows this problem as it’s happening?

In my device I don’t have the option cuz I don’t use mobile

What sort of computer do you have?
Which operating system do you use?

Are you doing it on a fresh document with the image copied to it? Or editing an image? Check your documents color settings.

Also, pretty much any OS has a print screen. For computers there is the print screen button. If your keyboard doesn’t have it, there are alternative combo commands to do a screenshot that will be either saved or loaded into your clipboard(so you can paste it). For windows I think it is fn+logo+spacebar and it will go to your pictures folder.

How can I check my colour settings

I use Windows 7

There are some unfortunate things happening here:

  1. The image you posted shows a krita window cropped on all sides. Is this actually what you see on your screen?
    Do you have a 1324 x 554 monitor?

  2. You’re using Windows 7, an operating system that was abandoned by Microsoft, 18 months ago.
    There is no way that the developers can make sure that version 4.4.3 works on Windows 7.
    I think you can still get free updates to Windows 10 or you may want to try switching to a Linux operating system, which is free but has a steep learning curve if you’re used to Windows.

  3. However, if 4.4.3 seems to be almost working on your computer, you may as well try to get it fully working in some way.

  4. You’re using a colourise mask which is not an easy thing to learn to use, if you’re new to krita, but good luck with that.

  5. Your canvas image shows a blueish fill but the layer thumbnails shows an orange type of colour.
    This suggests that you have colour channel swap over between red and blue.
    This usually indicates a broken video driver of some kind.
    With a new image, what do you see if you paint lines of pure red, pure blue and pure green?
    If you go to Settings → Configure Krita → Display and change the preferred renderer from Open GL to Angle (or the other way around), press OK and restart krita, does that fix the colour problem?
    If you go to Settings → Configure Krita → Display and disable Canvas Graphics Acceleration then press OK, does that fix the colour problem?
    (Can you see the top menu bar on your screen?)

Can you please try this: go to Configure Krita → Display → and change Renderer from ANGLE to OpenGL (or the other way around), and then restart Krita. Does it work?

@Ahab see that on the Layers docker it shows orange instead of blue; that’s usually the symptom of that stupid graphics card issue. Overview docker would show orange, too, only the canvas would have the colors swapped.

Yes, I thought I dealt with that in point 5.?
I’ll use bold next time :slight_smile:

Oh sorry! I guess I missed that somehow :frowning: And here I was thinking I was saying something useful :smiley:

1 Like

You always do say something useful but you were a bit late :slight_smile:

1 Like

In 5 point second part worked out but only for the saved once and not for the images I am doing at present instead it’s filling whole page

What exactly is the ‘second part’ that worked out?

What is filling the whole page?

Can you please upload screenshots to show the problem because these are much more detailed and accurate than written descriptions.

Have you tried using a new image and painting brush strokes in red, green and blue and noted the result?
If not, please do that and reply here to give the result.

Do you have any answer to my question 1.?

If you go to Settings → Configure Krita → Display and change the preferred renderer from Open GL to Angle (or the other way around), press OK and restart krita, does that fix the colour problem?
If you go to Settings → Configure Krita → Display and disable Canvas Graphics Acceleration then press OK, does that fix the colour problem?
This is 2nd part I sai

Not sai it’s Said

This is it

You are now producing screenshots that show the entire krita window so that’s good.
I don’t know what the white rectangle along the top is doing there but if it doesn’t affect your ability to use the menu items then I suppose it can be ignored.

You now have the canvas showing the correct colour so that’s good too.
However, it’s not clear what exactly you did to get that fixed.

Did you:
a) Go to Settings → Configure Krita → Display and change the preferred renderer from Open GL to Angle (or the other way around), press OK and restart krita.

Or did you:
b) Go Settings → Configure Krita → Display and disable Canvas Graphics Acceleration then press OK

Or did you do both of those things?

If doing only a) fixed the problem then you didn’t need to do b) and so you should set Canvas Graphics Acceleration to enabled again.

If you had to do both of those things, there is a problem with your graphics driver that can probably not be fixed and some things will be very slow, such as zooming.

For the orange fill covering the entire canvas, that is to do with the settings for the Fill Tool in the Tool Options Docker which is in the same docker group as the Layers and Advanced Colour Selector docker, as you have them arranged.

If you have problems using the Fill tool, please start a new topic with a suitable title for that.

Note: You have the Animation docker enabled and it’s taking up valuable screen area. Unless you’re doing an animation then I suggest that you close it using the ‘X’ icon at its top right corner.
You can get it back again with Settings → Dockers, then tick its box to enable it.