Does krita support Gaomon Tablets

Type of device* : Display tablet
Brand and version of the device: Gaomon Display PD2200 with V16.0.0.37 driver
System** : windows

* graphics tablet/display tablet/2-in-1 laptop/Android tablet
** Windows/Linux/Mac/Android, + version (you’ll find it in Help -> Show system information for bug reports)


Description of the issue (you can include screenshots): The software worked in the beginning after my the tablet purchase. Then it started giving issues such as no pressure sensitivity, the eraser icon and hot key not responding. I have tried reinstalling the software and the driver but to no avail. I would really appreciate the help as I love this software which help me a lot as a beginner artist and animator. I would be sad if I am not able to enjoy Krita 5.0. Thanks for the help! :slight_smile:

Hello and welcome to the forum :slight_smile:

Krita will work with any tablet that correctly provides data in accordance with the Wintab or the Windows Ink standard and which has been set up and configured correctly to work with krita.

You say you’re using a Windows operating system. Which version number?

You also say that it used to work in the beginning and then it stopped working.
Reinstalling krita will have no effect at all.

When you reinstalled the driver, did you do a full power down restart after uninstalling the old driver and did you then get the latest driver from the Gaomon website and then install that?
The driver must be installed in accordance with the manual instructions and these can vary.

Have you gone through the settings in krita and in the Gaomon utility to make sure they are ‘sensible’ and are as they were when you first set it up when you first got it?
Are you set to Wintab or Windows Ink in krita? Is this matched by disabling or enabling Windows ink in the Gaomon utility.
Have you accidentally turned on mouse mode in the Gaomon utility?

If you do a search on the forum, you’ll find that some people use the Gaomon PD1560 which is a similar type of display tablet and some of them has problems which were fixed by changing settings in krita, in the tablet driver setup/config utility or at the Windows system level.

Please have a look at those to get an idea for possible solutions.

3 Likes

Hello!! :slight_smile:

Thank you for the reply!

I am using windows 10 pro V10.0.19042

Yes I have done a full power down and restart after I have uninstalled the old driver. I have downloaded the latest driver again and installed it as an administrator. The driver was accordingly installed. The manual says that it will be done automatically.

Both settings of Krita and Gaomon utility were as it is when I have bought the tablet.

Regarding the Wintab or Windows ink I searched it in the software and matched it accordingly by disabling or enabling windows ink in Gaomon utility. However the result did not change.

No the mouse mode was not touched.

Here is the link to some pictures I have taken of the software where the options in the drop-box from the main tool bar are not displayed. You could see that in the configure Krita picture too. I hope this might bring you more clarity?

https://drive.google.com/drive/folders/1uAXnzuCpeKkraHLb386IN7VSe9B4c0Kk?usp=sharing

All in all, thank you so much! I am looking forward to fixing this problem. I really want to try the 2 point perspective tool in the latest Krita. :grinning_face_with_smiling_eyes:

Those screen photos that you provide via the link above show that you have a much worse problem that a tablet/stylus problem.
The missing menu items need to be fixed before you can start thinking about any tablet problems.

When was this? Which version number of krita were you first using?
Where did you get it from?

Did the problems occur in association with an event like a Windows update or installing some other software on your computer?

Which version number of krita are you using now?

Have you been trying the 5.0.0-beta1 by installing it or have you stayed with the 4.4.x version?

In C:\Users\{your username}\AppData\Roaming\krita is there a file called krita4.xmlgui or krita5.xmlgui?
If there is, delete it/them and start krita to see if that fixes the problem with your menus.

1 Like

Hello

Ok then lets tackle them :slight_smile: I bought the tablet around February this year so my memory is fuzzy, but I would like to think it was Krita 4.4.3. I downloaded it from your website.

I cannot tell you for certain if the problems started after an widows update but this is my first display tablet and I had a graphic tablet before. However, I would like to say that it might not be the graphic tablet driver’s fault because the software worked well.

I have not used Krita since then but kept downloading the latest version in hope it would solve by itself. I just downloaded the Krita 5 today after posting the second reply. I think I had Krita 4.4.8 before I downloaded the beta version which was from your website.

Regarding the directory I have added two more photos to the previous drive link where you can see that the mentioned files are not there. I checked in the folders above but to no avail too.

It’s not my website :slight_smile:

Exactly. If it worked before then something changed it, probably a Windows update. They are known to do that. However, the menu problem needs to be fixed first.

I think this is going to be one of those hairy/scary ones, for you, not for me.

It looks like you’ve used 5.0.0-beta1 as user ‘daily’ and maybe 4.4.8 as user ‘Kotabhi’.
Is that the case?
If you installed 5.0.0-beta1 using the installer .exe then both users will be using 5.0.0-beta1 because the Program Files installations are common across all users.
The way to ensure isolation between users is to have one of them running the portable .zip package which is available from the krita.org website.
Or, you may have done something fancy at the Windows level and set it up so that different users get different installations and use different versions.

So, what have you actually done and have you used the installer .exe or what?

When you ran 5.0.0-beta1, did it have exactly the same problem with the menus?

Before any consideration of tablet problems, you need to sort out the menu problems.

Disconnect the tablet and set your Windows system level display controls back to single monitor and then restart your computer, then use your mouse.
I don’t think that will fix anything but what happens?

Hahaha oops :sweat_smile: :joy:

I think we are closer to the solution. Let me explain. Yes I have used installer.exe, so you are right I have Krita 5.0 on both the users. However, if I open Krita in ‘Kotabhi’ it is working smoothly the menus and pressure sensitivity included! (I had to double tap on the eraser, vertical and horizontal mirroring icons to make activate it. Is that a new feature?)

But this actually scares me because I can easily start using this user for my artwork but not actually solving the issue. What happens if this gets issues later in the future? I do not want that.

I will isolate ‘daily’ with the portable zip file and try it out. (from your website :slightly_smiling_face:)

Another point is that when I downloaded the Gaomon driver I installed it as administrator. But I could not uninstall when I was using ‘daily’ user and I had to switch users just to remove the driver. (‘Kotabhi’ is the admin user by the way). Was this necessary to point out?

Regarding your last point I thought it would be redundant because of this new information but I did it anyway. No change.

This is an update. I have downloaded Krita 4.4.8 from the portable zip file. The issue remained the same when I opened it, no pressure sensitivity and menu issue. But here is the thing, I ran it as administrator, it solved the pressure sensitivity problem and I can see the menus too. But the catch is I could only access the menus, the eraser icon and other with the mouse but not with the pen. I could not tap on the new file icon but I could start drawing with pressure sensitivity after clicking on the same icon with the mouse.

In my view, I can see that this is more of a Krita problem than a driver problem. Please correct me if I am wrong.

All over the world, a very large number of people have been using krita version 4.4.x on Windows 10 computers with a large variety of different tablets, including Gaomon display tablets, and they are not having tablet problems. For the 5.0.0-beta-1, many people are trying it and there are no reports (that I’m aware of) that tablet functionality of various kinds are being broken.

You have two different users with different levels of permission and authority and a problem that arose some time ago and which now appears to have been mostly ‘fixed’ for your main/administrator user. This apparent fixing seems to be associated with your recent activity on your computer, for which nobody but yourself knows the full details.

In my view, this is a Windows-Gaomon-permissions-configuration-setup problem, not a krita problem.

That doesn’t surprise me but it’s useful to know.

What I suggest you do is as follows:
Forget about ‘daily’ for now and only use ‘Kotabhi’.

Make a backup copy of your configuration files and your resources folder, mostly so you can restore any custom brush presets, brushes, workspaces etc that you may have created and want to restore later.

Copy-paste the contents of the krita-sysinfo.log configuration file in a reply here. This may contain useful information and it’s not all that large.

Delete all the configuration files. These are in:
C:\Users\Kothabi\AppData\Local and are called krita(something).

Delete the resources folder. This is:
C:\Users\Kothabi\AppData\Roaming\krita

Run krita and see if the menus and everything else is working properly with the mouse.
If so, see if everything is working properly with the tablet.

Hello

Here is the krita-sysinfo.log configuration file you have asked for:

Krita

Version: 5.0.0-beta1
Languages: en_GB, en, en_US, en
Hidpi: true

Qt

Version (compiled): 5.12.11
Version (loaded): 5.12.11

OS Information

Build ABI: x86_64-little_endian-llp64
Build CPU: x86_64
CPU: x86_64
Kernel Type: winnt
Kernel Version: 10.0.19042
Pretty Productname: Windows 10 (10.0)
Product Type: windows
Product Version: 10

OpenGL Info

Vendor: “Google Inc.”
Renderer: “ANGLE (NVIDIA GeForce GTX 1060 Direct3D11 vs_5_0 ps_5_0)”
Version: “OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)”
Shading language: “OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)”
Requested format: QSurfaceFormat(version 3.0, options QFlagsQSurfaceFormat::FormatOption(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::CompatibilityProfile)
Current format: QSurfaceFormat(version 3.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
Version: 3.0
Supports deprecated functions false
is OpenGL ES: true

QPA OpenGL Detection Info
supportsDesktopGL: true
supportsAngleD3D11: true
isQtPreferAngle: true

Hardware Information

GPU Acceleration: auto
Memory: 32610 Mb
Number of Cores: 12
Swap Location: C:/Users/Kotabhi/AppData/Local/Temp

Current Settings

Current Swap Location: C:/Users/Kotabhi/AppData/Local/Temp
Current Swap Location writable: true
Undo Enabled: true
Undo Stack Limit: 30
Use OpenGL: true
Use OpenGL Texture Buffer: true
Disable Vector Optimizations: false
Disable AVX Optimizations: false
Canvas State: OPENGL_SUCCESS
Autosave Interval: 900
Use Backup Files: true
Number of Backups Kept: 1
Backup File Suffix: ~
Backup Location: Same Folder as the File
Backup Location writable: false
Use Win8 Pointer Input: false
Use RightMiddleTabletButton Workaround: false
Levels of Detail Enabled: false
Use Zip64: false

Display Information
Number of screens: 2
Screen: 0
Name: \.\DISPLAY4
Depth: 32
Scale: 1
Resolution in pixels: 1920x1080
Manufacturer:
Model:
Refresh Rate: 60
Screen: 1
Name: \.\DISPLAY1
Depth: 32
Scale: 1
Resolution in pixels: 1920x1080
Manufacturer:
Model:
Refresh Rate: 144

I am sorry but I am a bit confused here. Since Krita under ‘kotabhi’ is doing fine, shouldn’t be the file destination be under ‘daily’. Such as:

C:\Users*daily*\AppData\Local and are called krita(something)

Or is it ok to do as you suggested?

Furthermore I could not locate the configuration files. was one of them called kritarc?

There was not resource folder in the file destination regarding the last suggestion.

As a matter of interest and relevance, I tried using my Windows 10 system with the main/administrator user and the other/non-administrator user.
They can both run the common installed version 4.4.8 and the local portable .zip version 5.0.0-beta1 with no problems.
The Wacom tablet works fine for both those users. The setup is for Wintab and there may be a possibility that when using Windows Ink that those different accounts have different Windows Ink settings. I’ve never dug around in that area of experimentation and testing.

Regarding user ‘Kothabhi’, you said:

No, it’s not a new feature so there is still a problem with user ‘Kothabi’, isn’t there?

Exactly. So it was my intention to fully sort out user ‘Kothabi’ first in all aspects of operation including the display tablet. It seemed like a good idea to me.

The main configuration file is called ‘kritarc’. There are other smaller and more specialised ones in the same location and since they all are called ‘krita(something)’ then they should all be together in an alphabetic folder content listing.
You found ‘krita-sysinfo.log’ so I can’t understabd why you didn’t find the others. As a minimum, there should also be ‘kritarc’ and ‘kritadisplayrc’.

That is strange because your screen photos (-6052 and -7702) show the File Explorer presentation listing of the krita resources folder for both ‘Kothabi’ and ‘daily’. So, how did you get those photos?
Let’s concentrate on ‘Kothabi’ for now.

Hello

I apologize for the previous post. I was so focused in finding a folder named ‘Resources’, it did not occur to me that those files were actually the resource bundle files. My apologies.

So going back to your suggestion, yes I have deleted those files in both the file destinations and checked with the software. It worked properly with the mouse, however the same problem persisted with the pen. I played around and found out that it is registering double taps when I have tapped only once. I hope this helps.

I do not require any backup because I use the the brushes given by the software and the workspace is easy to setup again. Yes lets focus on ‘Kotabhi’. :+1:

If I remember correctly, this is a Windows Ink thing where a long press is interpreted and sent as a double tap.
Do you still get a double tap if you’re careful to do a short touch?
Either way, you need to look in the system level Windows Ink settings (search for ‘pen’ and ‘ink’ and you should find the link to those settings.
It’s also one of the buttons that you get if you click the settings icon at the right side of the system tray.

This level of complication could be avoided if your Gaomon tablet was set to disable Windows Ink and in the krita settings you choose Wintab.
However, this would rely on the Gaomon tablet correctly providing stylus pressure levels when using Wintab.

I suggest that you try setting krita to Wintab and disabling Windows Ink in the Gaomon settings utility and then test and check to make sure that all aspects of the tablet/stylus operation are working properly. (Press any ‘OK’ button and close the Gaomon utilty to ensure any changes are fully registered before trying krita.)

If Wintab gives a loss of functionality then you’ll have to go back to Windows Ink and deal with the additional settings at the Windows system level for Windows Ink that are involved.

Hello

Yes I get the double tap if I just do I short touch. I did as you suggested. I played with Wintab and windows ink and checked if it worked. The problem did not change whether it was wintab or windows ink.
However, I found one thing. When I activated the option ‘Let me use my pen as a mouse in some desktop apps’ which was found in the pen and ink settings, the double table issue stopped for the most part except the menu tool bar. I could minimize a window without the double tap issue but the problem persists with Krita’s main tool bar. I can press once to activate the eraser and alpha lock button though which was a good thing.

But if I turn it off, what I would get is that when I tap ‘settings’, it would flicker as if it was double tapped while in the case where I turn it on even I long tap the ‘settings’ it would not respond.

Regarding the windows pen and ink setting this showed some response.

OK this is another update. Please check the drive link again as I have added two more photos. I think this might give an answer. There are two versions of the same drivers in the system. one is V13 while the other is V16. I have tried to remove the V13 before I updated my driver but I received a response that the file directory does not exist please try another name. Reading this I assumed that the V13 driver was removed just the appearance of the file remained. It had no Gaomon symbol like the V16 which gave me confidence to go ahead with V16.

If this is the source, I can tell you that I have tried removing it but I receive the same response as above. So, could this be the source in your view. If so, is there another way to remove it?

So, you also have a gaming mouse driver installed and what appears to be a ghost tablet driver. It’s hardly surprising that you have problems.
Some gaming mice cause interference with tablets and it’s known that the Razr mouse can do this. I’ve no idea about the GSkill Ripjaws.

I should have asked you, “Do you have any unusual fancy peripheral devices connected?”. I should also have asked, “Are you sure that you fully uninstalled the old driver?”

That gaming mouse driver was installed a week after you installed and started using the Gaomon tablet. Did your initial problems with the tablet start about a week after you first started using it?

I suggest that you do the following:
Disconnect the gaming mouse and connect a normal mouse instead. Do a full power down restart.
Uninstall the gaming mouse driver then do a full power down restart.

Check to make sure the gaming mouse driver has gone or if it has a ghost entry of some kind.

Either way, see if the problems have gone or if they can now be fixed in some way by krita or Gaomon utility or Windows Ink settings.

If they can, fine, don’t use that gaming mouse again.

If they can’t, disconnect the Gaomon tablet and then uninstall the old Gaomon driver and then the newer Gaomon driver.
At every stage, whatever action you perform, do a full power down restart and then check that the driver has been uninstalled.

If you still have ghost driver entries then that may be a problem and I’ve no idea how Windows works at that level. Something is ‘registered’ or is being detected somewhere or it wouldn’t show as it does.

One possibility would be to use your Windows 10 installation DVD and do a System Repair.

When (and if) you finally have a ‘clean’ system, and have made sure that you have a clean system, run krita with the normal mouse and make sure that it works fully.

If it does, you can then install the latest Gaomon driver in accordance with the manual instructions and hopefully set it up and get it working properly.

Hello

I see. I would like to tell you that I have bought that mouse way before I bought the Gaomon tablet. It should be the date where the latest driver was installed. That’s for sure. So no problems from the mouse driver.

I have only the fancy mouse, that’s all. Regarding the old driver uninstall, I have searched for the file in the computer with no results. The only thing left was the ghost drive which you saw in the photos.

Regarding the suggestions I will do as you say. If there is change I will let you know. If not, I will try a full system reset. I am sure that should work.

I have an unrelated question. Do I have to wait in order to access the new topic in the art section? I would like to post some of my old art and animations for the community but the new topic button is deactivated.

All in all, thank you so much for what you have done until now. I really appreciate it my man. Never had this kind of personalized help. Thank you! :smiling_face_with_three_hearts:

1 Like

The previous mouse driver may not have caused problems but how do you know that the latest mouse driver did not cause problems?
Answer: you don’t. There’s only one way to make sure.

Those ‘ghost drivers’ are annoying and worrying and that side of things needs advice from someone who knows the deeper workings of Windows.

As a new member, there are some limits on what you can do and how often you can do things. These limits will be lifted as you use the forum more.
I’m surprised that you can’t make a new topic at the moment.
@raghukamath will know more about this.

You’re in a very good forum with very good people :slight_smile:

1 Like

I am back.

Did a full system reset and got rid of the ghost drives. Its a clean slate. Is there another way to check whether it is clean or not? I have downloaded Krita 5.0 and changed the tablet settings to windows ink. It worked well with the mouse. I will restart after every action and let you know

Update 1: Downloaded Krita and change the settings to windows ink. Restarted the computer. No change and no changes in the tablet settings.

Was that a ‘system repair’ or a full reinstallation?

If they’re not showing in the driver list then that sounds good. I don’t know of another way to check.

If you can get it working with Wintab, that would give you a less complicated situation by avoiding Windows Ink settings problems.
If that can’t be done then you’ll have to use Windows Ink.

Are you now running with a normal mouse or have you installed the gaming mouse?

1 Like

This is the second update. I have downloaded the driver and installed it accordingly. I have done a full power down restart and checked everything with mouse and stylus. All of them are in order. The pressure sensitivity was good as before, I could single tap and open the menu bars in the main tool bar. I could activate the eraser icon with one touch. This has solved our issues.

This was a full reinstallation

Regarding Wintab I heard the windows ink was better than that so I took a gamble and it paid off. Krita 5 runs now on windows ink and the Gaomon utility app has windows ink activated.

Regarding the mouse I have discarded the gaming mouse removed the driver before the reset and I am using a normal mouse from now onwards. It feel a bit weird after using a gaming mouse though.

Now all I have to do is to transfer the backup files and I am quite sure that I am back on track

What I have understood that something went overcomplicated with all the new updates at windows level and the two users. Unfortunately, some of it was beyond your help too. But with a new slate, if I ever encounter a new issue, god forbid, I now have less factors to consider before solving it.

Thanks my man. You were really great throughout.

1 Like