fatal IO error 22 (Invalid argument) on X server ":1"

‘/home/bleke/Desktop/krita-5.0.0-beta1-x86_64.appimage’
The X11 connection broke: No error (code 0)
XIO: fatal IO error 22 (Invalid argument) on X server “:1”
after 469 requests (469 known processed) with 0 events remaining.

Ok… I’m not sure what the invalid argument is.

Can this be fixed easily? Otherwise I’ll stay on Krita 4.x.

Does it only happen with Krita 5 beta?
I assume you didn’t edit your X11 config file manually, right?

Yes to both. This is also the first time I try an appimage.

My 4.3((?) I’m at work, don’t remember the exact version) install is a .deb

Do you have multiple Displays? :1 could be part of a display assignment (perhaps Krita trying to start on a monitor that isn’t connected anymore but I’m really just guessing) but I don’t think there would be much you could do about it then. Except maybe deleting one of Krita’s config files, I vaguely remember there is a display config xml somewhere for Krita.

I assume you are on Ubuntu or other *buntu?

1 Like

I do have a monitor and a Cintiq. But both were running when I tried to use the appimage, and I had just closed Krita 4.x which worked fine.

I’ll try removing the config files when I get home tonight.

I’m currently on Pop OS, but just yesterday I downloaded Void Linux. Hopefully I’ll get time to try it out during the weekend.

Removing the config files alone didn’t work, but in combination with a system upgrade and a reboot I got it working! :+1: