How can I disable desktop compositing in Linux Mint?

This might not be a Krita question but…

I want to disable desktop compositing in Linux to avoid my tablet’s input delay in Krita, but I can’t. I’ve tried almost everything I could find on the internet. Any advice?

The OS version is Linux Mint 19. 3 Cinnamon.

Only kwin allows that; mutter and other gnome-based window managers don’t.

I think View > Fullscreen Mode (Ctrl+Shift+F) in Krita bypasses compositing, I’m not entirely sure how the window compositors usually handle it.
Are you sure that’s the problem causing input delay and is this a Krita specific issue? Did you try adjusting the brush smoothing settings or the Dynamic Brush Tool?

That’s interesting - I’ve spend like 2 years in fullscreen mode on Ubuntu 16.04 (unity) because krita was running noticeably smoother than as the usual window.
The problem disappeared when I switched to kubuntu (plasma). I never knew what caused the issue.
It would be great to know, if in fullscreen, you still notice this lag.

Could you suggest the best Linux Distro for using Krita?

Kubuntu will be good

1 Like