krita 4.4.1 issue

i have an issue with krita 4.4.1 update. that problem makes this program unendurable. the problem is that at some point I can use the express keys i can zoom in and out but I can’t move the canvas! I tried everything, I used the configure krita and went to tablet settings, and it didn’t work, i reinstalled my driver for the kamvas 13 and that hadn’t worked either! i am super fibbin peeved! this is the crap that needs to be fixed! its not the fault of the driver, its the fault of the program! please fix it!

i’m sorry if i sounded rude, but this problem is making me mad! i love krita, but i do not want it to be unusable like this, is there any way to fix any developer to update this?

Can you check if it works after you select a different tool and switch back to the previous tool?

When reporting a problem, please provide at least information about the operating system you are using, the version of the driver you are using and in this case, which of three or four different ways of moving the canvas you are talking about.

If you are on Windows, you will also have to make clear whether you are using Krita in wintab or Windows ink mode.

In the meantime, I will contact Huion and ask them about it, because it is, after all, unlikely that this is actually a bug in Krita.

Dude, it’s not huion’s fault. And I don’t think it’s the fault of the driver, I know this because I used the keyboard to test if it’s not the fault of the driver, i used the spacebar expecting a different result. And I can’t move the canvas with the keyboards nor can I used the keyboard. I’m not trying to be egoistic, but I think everybody has the same issue as me because my driver works just fine. I should have said it a little better.

And I am using the kamvas 13 as the main tablet for digital art.

Sorry, I’m done trying to help you.

Look i’m not saying that your not help me, i appreciate what your trying to do here, I’m letting you try if it’s huion, I could be wrong for what I’ve said.

I don’t have this problem on Linux Mint on Yoga.

If you use only your keyboard and a standard computer mouse, does it work if:

  • you press Space and drag with the left mouse button?
  • you draw with your middle button?

No, i did not use keyboards only, sometimes I used the keyboard in some cases. But yes I did two potions you’ve said, and no it didn’t work. And sometimes it may fade away but then it comes right back. And in another case, it’s the same but the difference is that it rotates the canvas around a little bit, I can use the shortcuts just fine, I can zoom in and out and draw, the only think that is buggy is movingg the canvas, which is annoyingg if youu ate trying to ad more detailing into your work.

I’m asking you to test it with just a keyboard and a mouse, if you have both laying around somewhere. This is important to determine what is responsible for the problem and how to fix it :slight_smile:

I don’t know how to fix this though, it’s like me in a pitch black night while trying to solve a labirinth. If you had that issue with krita how would you fix that?

In case you couldn’t tell what I ment, I either pressed space bar or use a mouse In your case (because I usually use my pen desplay) usually your mouse icon becomes a hand that grabs the canvases as you move it around, but the bug is that the hand does not appear at all, and you can’t move the canvas.

I’m asking you to check if it works if you use a mouse or not. Please open Krita, press the Spacebar and then press the left button on your mouse and try to move the canvas.

I will tell you how to fix that (hopefully) but first I need more information.

it doesnt always happen in krita, sometimes i can move the canvas, and other times i don’t. so it will be just a random accourance. but when it does happen i will check if it works.

i will give more information as best as i can because i’m not an expert at computers and stuff so please hear me out. as i said sometimes it works sometimes it doesn’t, it randomly accours, one user said that i just have to reinstall my driver for my huion kamvas 13, but that didn’t work and i doubt that doing it multiple times would work either, i think its the program that was the cause of this because i checked to see if the art ptograms have the same issue like autodesk sketchbook, and it didn’t have the same issue. i turned on ink mode from krita and went into general setting to find the solution to this problem but didn’t know what to use. usually i went into a browser to play some music while i draw, and when i went into krita, issue happened. and it happened maybe 7 times, and it does not always happen, but it its really annoying if you were trying to had more detailing to your art. i tried restarting krita and usually it doesnt work. whitch is why i made a topic about it 2 times to see if any developer can either help me fix the issue or at least update it if any tactic does not work. and thats literally all I know.