Krita 4.4.3 start up error - damaged


I hope this is the correct place to post this. I just downloaded krita 4.4.3 for MacOS. After my first download, and installing the app over 4.4.2, I got an error trying to start up 4.4.3 saying that krita was damaeged and I should move it ti the trash. I did so and reinstalled the app from my initial download. I got the same error while MacOS was trying to verify the app during start up. So, I doenloaded the app again and reinstalled fresh. Again, for a third time, I got a warning message that 4.4.3 was damaged and I should trash it.

I am running High Sierra on a patched 2008 Mac Pro.

Any idea what could be causing this issue?


1 Like

I’m running High Sierra as well, and I’m running into the exact same problem. I tried diagnosing what I could of it, couldn’t find anything interesting in the Console except for a bunch of spew from syspolicyd (which isn’t really out of the ordinary).

4.4.2 works for you, but not 4.4.3? Maybe I’ll try to find a .dmg for 4.4.2 and see if it works for me.

I hope 4.4.3 does not actually require a newer version of macOS than the system requirements listed on (macOS >= 10.12) …

BTW – 2008 Mac Pro? That is ancient hardware, I’m glad it still serves you well.


Krita 4.4.2 download links: KDE - Experience Freedom!

Also it might be a problem with signing or authorization… @IvanYossi ?


Yes, 4.42 works for me. so I’ll be re-installing it. And yes, the Mac Pro is old, but it is new to me. I just bought it shortly after Christmas. I was previously using a G5 DP 1.8 :smile:

Thank you very much for posting the link to the previous version. :vulcan_salute:

Thanks for the link. 4.4.2 runs perfectly. Earlier this evening, I found on my own, and that launched just fine as well.

It does kind of smell like a signing or authorization problem to me, too, somehow.

I don’t think is signing or authorization, because it runs fine on newer macs, like my 2015 macbook pro with Mojave. It’s more likely that changing the build system to make universal binaries has changed the minimum macOS version accidentally. It’s quite possible that the latest xcode doesn’t have support for older versions of macOS without resorting to tricks.

1 Like

I’ve run into the same issue and found out there are other people getting the same error on different software. And there is a workaround on youtube. You could try to open the terminal and then type “sudo spctl --master-disable”
This will add an additional option when you go to “Settings > Security & Privacy > Allow apps downloaded from”. You have to check “Anywhere”. Then it should work.

Another workaround was suggested by @IvanYossi:
"first test there is a quarantine flag typing in terminal xattr /Applications/ and hit enter. the results will return “” and maybe other results. This line is a flag and tells macos to check for signature as the file comes from the internet.

to remove the flag type: xattr -d /Applications/ you can check the flag is removed by typing the first command and see the quaratine flag gone."

Hope it helps!


This is not a signing problem at least not a sign problem from our side. We send to be signed and verified to apple servers, when there is a problem the app gets rejected. Adding universal binaries probably si messing on how older systems check for signatures. I suspect this as trying to pack the dmg as HFS+ never succeded, however on APFS there was no problem.

You could do what I suggested @oliver and remove the flag


Yikes, hmm, okay.

It’s very easy for me to accept that adding universal binary support has accidentally changed the minimum supported OS. Maybe there’s some documentation from Apple which would confirm this…

At any rate, I confirm that removing the extended attribute lets 4.4.3 run OK for me, so thanks for that!


Thank you for finding and posting this. I will try this later.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.