Krita 5.0.2 alpha lock and group layer not working? Help?

Been using krita on windows for a while, but never had this happen to me. For the last few days I’d be using krita, open up a group layer and use it to start shading. the first problem is that whenever I select the multiply layer option inside a group layer it acts like its still on normal. when I move the layer outside of the group it works fine, but move it back in and it reverts.

Layer by itself

In a group layer

I’m not Removing the multiply effect, but its doing that regardless.
My second problem showed up even more recently, alpha lock just doesn’t work. i dont know why, but it wont conform to the layer under it.

No alpha lock

Alpha lock

I know this is kind of long but these two function are ones I use all the time, if anybody has any answers, please send help!

  1. The first problem is that a group layer will composite the layer inside the group and treat the group as a single layer. The “Paint Layer 4” doesn’t have a layer to blend under “Inside The Group”
    So in your case, if you want to Multiply Layer 4 with Layer 2, you should (a) set “Group 5” to multiply the layer below. (b) or put “Paint Layer 2” inside the group.
    About Group Layer: Group Layers — Krita Manual 5.0.0 documentation
    Introduction to Layers and Masks — Krita Manual 5.0.0 documentation
  1. Actually, alpha lock is on the right side of the icons, which only lock alpha in the exact same layer. What you click is “Inherent alpha” , which will inherent alpha from the layer beneath it “Inside The Group”
    In your second problem, if you want Paint Layer 5 to “Inherent alpha” from Paint Layer 2 in the last screenshot, group layer 5 and layer 2 inside a group, layer 5 will inherent alpha from layer 2.
    About Inherent Alpha: Introduction to Layers and Masks — Krita Manual 5.0.0 documentation
3 Likes

Ok, the second one makes sense, but the first one shouldn’t be like that. I’ve used group layers multiple times without needing to change it to another filter layer to get the effect I want on the paint layers inside.

If you look at your previous projects, you may notice that those groups contain more than one layer with one of the layers set to Multiply, unlike the situation you show in your second screenshot where the group only has one layer in it.

In addition to AhabGreybeard said, if you have saved your previous project in .psd format, the group layer will automatically enable Passthrough mode, which will open up the compositing to all the layer under it.
Passthrough Mode can be enable manually in .kra files, the button is on the right side of Group Layer, looks like a brick wall.