krita 5 beta 1-2 Brushes sluggish just at the start of the stroke

hey, i have bumped into this lil annoying thing, some brushes at the beginning of a stroke are very slow, it feels like when you use big textured brushes but it gets to speed after a second until you let go it works fine without any delay, it gets unusable if you have to do a lot of little strokes with the affected brushes, krita just starts processing for very long…

it doesn’t happen on 4.4.8 and different brushes have that issue between the krita 5 Beta 1 and 2…

oh yeah an i’m on linux

3 Likes

some examples

krita1
krita2

1 Like

Something similar happened to me, it might be a different issue but what worked for me was using, changing size and drawing with a default brush, then suddenly my custom brushes worked fine. Very weird bug and solution on my end haha

1 Like

Also aaa my brain just registered one of the brush sets on the screen, thank you for downloading, hope you enjoy it so far and thanks foe testing :heart_eyes:

1 Like

To trouble shoot try it with Pigmento turned off.

1 Like

i love your brushes, the issue is not isolated to them tho… i have that same problem with other packs, the strange thing is the same brush work perfectly in beta 1

1 Like

i disabled all plugins, i am using the same brush in all 3, (rbr) SoftBreez

Krita 5 beta 1
beta1

Krita 5 Beta 2
beta2

Krita 4.4.8
4.4.8

for some reason the beta 1 SoftBreez looks so different…

2 Likes

I also experienced this with the new version. I thought initially it’s the new PC cause it coincided with that: Pattern not loading sometimes - #9 by razcore-rad

What worked for me is to save the brushes with the new Krita version. So for example, change size by 1 pixel up, change it down again, overwrite brush preset.

3 Likes

So the pattern works in beta 2 but the lag on some brushes is just killing me… do you still have lag?

Since it worked for me no, I don’t have that lag any more.

1 Like

i tried but it still lags… T_T

Bummer. Resaving worked for me, other than that I don’t really have any ideas.

1 Like

See 443629 – Heavy lags in brushes with patterns in beta2 and Fix loading of textures in presets with invalid MD5 tag (!1098) · Merge requests · Graphics / Krita · GitLab , it’s merged so it should be better in next nightly build. Though Dmitry writes there thst he’ll be still working on related issues.

4 Likes

so it’s just a question of time before the bug gets squashed, thanks guys for your work…

If beta2 is hard to use (it was the case for me, harder than beta1), you might want to upgrade your beta2 with “Krita plus” (because the fix to this lag is already part of 5.0 code branch since 3 days). It might be quicker than waiting for beta3.

To get it, go to the Download categorie of Krita website: Download page − krita.og and on the bright part under, column in middle Nightly Builds , take “Krita plus, Daily builds of what will become Krita 5.0”.

3 Likes

i tried the plus and next version… but the same brushes still have that issues, it’s infuriating when your favorite brush doesn’t work, it feels like “f*ck you in particular” xD

ooof i just noticed who you are, let say it made me happy, i love your style :stuck_out_tongue:

1 Like