Krita is dropping keyboard inputs (or it's something else)

Hello, I recently updated to krita v 4.4.5 from a version around Nov 2020 (sorry, can’t remember the specific version) and have noticed strange behaviours regarding panning and rotating the canvas.

For some reason while I pan/rotate krita will eventually ‘drop’ the spacebar input and treat the canvas as if I were doing another function. For example if I was rotating and panning around the canvas using the default keys Shift, Space and Ctrl, it will just stop randomly and I will end up drawing across my canvas trying to pan, or bringing out the colour picker even though I’m still holding down Spacebar.

I’ve tried changing Canvas input settings as well as resetting to default but none of them seem to work. If anyone knows why I will grealy appreciate your help thanks.

OS is Windows and i’m using a wacom bamboo tablet.

:slight_smile: Hello and welcome to the forum @shiyunkc!

Do you have the possibility to test with another keyboard to rule out that it’s a “slowly dying” or “occasionally going crazy” keyboard? However, I know that similar malfunctions have already been described here.


Thanks, I have tried with a different keyboard including watching a key tracker at the same time and it shows no signs of my keys being mispressed or anything. I don’t know if this is a bug or not but I have confidently found a way to recreate this issue (if it is a bug)

If I hold spacebar and spam ctrl (switching between zoom and pan tool) it will eventually give up and ‘forget’ i am holding spacebar meaning I will be switching between the brush tool and colour selector instead. The same applies for holding space and spamming shift (sticky keys off). This might sound like a ridiculous scenario but it replicates what I am experiencing normally, where I would alternate between panning and rotating and zooming etc. I also noticed this only occurs if my pen is being detected

The only thing I have also tried since is disabling some more key combinations under canvas input settings i dont use but I still experience this bug, unless I am missing some feature or something.


I am gonna test this. I have had the same issue but I never discovered the cause even though my keyboard now accepts 12 key presses at the same time or something like that without dropping inputs.

P.S.- Yes I managed to lock it a couple of time into the picker by spamming Ctrl.


Using that rapid key spamming technique, with 4.4.5 on Linux I don’'t see a problem though maybe I didn’t try for long enough.

With 4.4.5 on Windows 10, I do see this happen but it needs lots of spamming at first.
Releasing the Space keys sets it back to normal operation and then it’s easier to make it happen again.

Holding the Space key down and using stylus swipes, which are easier than mouse left-press-drags:

Spamming the Ctrl key results in the Space key being ignored, the Ctrl key giving a magnifying glass cursor but the stylus painting a brush stroke and the magnifying glass cursor turning into a brush cursor during the stylus drag action.

Spamming the Shift key gives a similar result with the Shift key giving a rotation cursor but the stylus drawing with the line tool and the rotation cursor turning into a line tool cursor during the stylus touch-drag action.
The Toolbox icon switches between Freehand Brush and Line Tool in this situation.

I have also tried to provoke this error, so far (fortunately) unsuccessfully. Only the cap of the Ctrl button fell off (but could be put on again), then I ended the attempt.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.