Krita is messing with my Wifi

So I have been trying to work in Krita for a while and I do enjoy it a lot but there is a strange bug that I (and a few others via a Reddit post) have encountered that really needs to be fixed. Whenever I open Krita the Wifi suddenly starts turning on and off. This does not happen when it is closed nor does it happen with any other art program on my PC. There is apparently a fix (in the Reddit post I mentioned) but unfortunately, I have not been able to figure out how to apply it. I have to input a command of some kind but when it comes to me and tech sometimes I really need someone to break it down for me. I’m putting the link to the thread here, maybe someone here can tell me exactly what I should be doing. I am using the Krita 5 beta now but I was also having this issue with previous versions. So I know it’s not the version that I have that is causing the problem. Also, in case it matters I’m using Windows 10.

Anyways this is incredibly annoying and I also just wanted to write this here so anyone else who may run into this issue will hopefully find this and reach a solution. Or better yet the team behind Krita fixes this bug in the future.

The thread you linked has a workaround in it. Does it help? according to the top answer in that reddit thread it is a bug in Qt the framework that Krita uses. Are you on a new version of krita? Also does disabling news update help you?

If you want to test adding the environment variable suggested in that thread, here’s a how-to on that.

https://kb.wisc.edu/cae/page.php?id=24500

Aha! Yes, thank you this is exactly the kind of step by step explanation I was needing! It took me a few tries to get it right but then I figured out that I was putting the path in wrong. Thank you so much again and I hope this helps others in the future.

I’ve finally figured out how to do the workaround. I don’t know how to disable the news update that you’re talking about but so far things have been working smoothly without having to do so. Thanks.

It looks like this has been resolved, but just in case, I’ll tell you where you can set up news updates. :slightly_smiling_face:


( Krita5.0.0-beta1 )

1 Like

Try disabling bug reports in Krita settings. Also, when you open Krita you have the initial screen and somewhere on it is a setting to download news. Disable that.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.