Krita Modify Selection not working

Hi, I need help every time I use the selection tool is very painful for me, no matter what, I tried looking in videos or Q&A but it’s like nobody has this problem, I tried re-installing but doesn’t work. I use krita from like 2 years ago, I’m in a new computer and installed a new version and this is what happens when I try to transform the selection.


Just in case is use Krita 4.2.8
I have Windows 10
Processor AMD A4-4000 APU with Radeon™ HD Graphics 3.00 GHz
RAM 8.00 GB

is that the expand selection command?

Yes, it also happens with the magic wand or any other thing like the bucket, it’s always vertically limited.

I think you found a bug, I have the same behaviour

you need to file a report on it. only way now is to do a post correction after the fact :\

Oh, well at least I was not the only one, thanks for the help anyways.

The expand selection bug is already fixed in master and the 4.2 branch. https://invent.kde.org/kde/krita/commit/b49d97897559691c98e692f0a9e6309e721b301f
You can try it by downloading one of the daily builds on the Krita website or wait for the next bugfix release.

Is there another issue mixed in that you encountered?

1 Like

Yeah I fixed that already, one can use “Krita Plus” version from the website to get it working.

1 Like