Layers become unresponsive

Type of device* : Huion
Brand and version of the device: Kamvas Pro 12-GT 116
System** :Windows 10

* graphics tablet/display tablet/2-in-1 laptop/Android tablet
** Windows/Linux/Mac/Android, + version (you’ll find it in Help -> Show system information for bug reports)Krita

Version: 4.4.2
Languages: en_US, en
Hidpi: true

Qt

Version (compiled): 5.12.9
Version (loaded): 5.12.9

OS Information

Build ABI: x86_64-little_endian-llp64
Build CPU: x86_64
CPU: x86_64
Kernel Type: winnt
Kernel Version: 10.0.19041
Pretty Productname: Windows 10 (10.0)
Product Type: windows
Product Version: 10

OpenGL Info

Vendor: “Google Inc.”
Renderer: “ANGLE (NVIDIA GeForce GTX 1060 3GB Direct3D11 vs_5_0 ps_5_0)”
Version: “OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)”
Shading language: “OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)”
Requested format: QSurfaceFormat(version 3.0, options QFlagsQSurfaceFormat::FormatOption(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::CompatibilityProfile)
Current format: QSurfaceFormat(version 3.0, options QFlagsQSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile)
Version: 3.0
Supports deprecated functions false
is OpenGL ES: true

QPA OpenGL Detection Info
supportsDesktopGL: true
supportsAngleD3D11: true
isQtPreferAngle: true

Hardware Information

GPU Acceleration: auto
Memory: 16263 Mb
Number of Cores: 12
Swap Location: C:/Users/terry/AppData/Local/Temp

Current Settings

Current Swap Location: C:/Users/terry/AppData/Local/Temp
Current Swap Location writable: true
Undo Enabled: true
Undo Stack Limit: 30
Use OpenGL: true
Use OpenGL Texture Buffer: true
Use AMD Vectorization Workaround: false
Canvas State: OPENGL_SUCCESS
Autosave Interval: 900
Use Backup Files: true
Number of Backups Kept: 1
Backup File Suffix: ~
Backup Location: Same Folder as the File
Backup Location writable: false
Use Win8 Pointer Input: false
Use RightMiddleTabletButton Workaround: false
Levels of Detail Enabled: false
Use Zip64: false

Display Information
Number of screens: 3
Screen: 0
Name: \.\DISPLAY1
Depth: 32
Scale: 1
Resolution in pixels: 1920x1080
Manufacturer:
Model:
Refresh Rate: 60
Screen: 1
Name: \.\DISPLAY2
Depth: 32
Scale: 1
Resolution in pixels: 1920x1080
Manufacturer:
Model:
Refresh Rate: 60
Screen: 2
Name: \.\DISPLAY4
Depth: 32
Scale: 1
Resolution in pixels: 1920x1080
Manufacturer:
Model:
Refresh Rate: 60


Description of the issue (you can include screenshots): When i am working on a layer, it would normally be dark blue and allows me to paint/draw, but lately the layer jumps to a light blue, and i can’t use any tools to paint/draw … I hit the active layer again with my mouse, and it stays dark blue for a couple of seconds and then disables itself once more.
I"m also suffering from my Huion tablet pen freezing while using the pan tool (hard button on the tablet) so i have to save/shut down Krita and start again, when the whole process repeats itself.

Hello and welcome to the forum :slight_smile:

When your active layer stops being active and stops being highligted as active, does any other layer become active, as indicated in the Layers docker?
Since you’re having problems with your tablet, can you Quit krita, disconnect your tablet from the computer, restart the PC and try again with just a mouse on the PC monitor to see if the problem doesn’t happen.

For the pan problem with the tablet button, what have you mapped the tablet button to?

If you map the pen button to ‘Space’ or ‘Middle-Click’, does that work ok to use for panning?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.