Making and testing the Android build from source?

Hi,

Samsung Galaxy Tab S3 (SM-T820)
One UI version: 1.1
Android version: 9
Security patch dated 2019-08-01

Don’t hesitate to ask for more detail.

Excuse me but, I downloaded android build 64 bit and it seems cool and the layout is perfect however I can barely seem to even create a file and draw. It’s mostly because I can’t edit the canvas settings, like my keyboard doesn’t show up. And some of the tools are out of sight.

Help??? Or like update it plz???

Edit: also I think there should be a back button to return where I last was. And I heard that you guys were aware of the ratio problem, So is there gonna be another built soon?

It’ll look small, but you can have less cramped space by changing your Android device’s dpi settings. Go to settings > developer options (enable dev options also) > minimum width.

Yes, we are aware of this problem. Unfortunately the solution to this would be a full UI rework, at least for tablet/mobile devices. This is something on our minds, but isn’t something that which is going to be fixed immediately.

You could try what @98adus9823dse suggests:

And increase the number under minimum width and then go to Krita and then turn off highDPI scaling. Then you can revert back the minimum width.

(but bear in mind that changing phone’s DPI settings can change your Homescreen Layout.)

1 Like

Oh, I have a Cintiq Hybrid Companion too, and don’t use Android on in anymore, just as a tablet for Ubuntu/Krita. Im not surprised, since Wacom never updated the system of the Hybrid Companion. But too bad that we cant use Krita / Android on it.

1 Like

Krita APKs based on current krita/4.2 branch.

Krita-arm64-signed.apk
Krita-arm32-signed.apk
Krita-x86-signed.apk

Hopefully this should work better than the previous ones.

Thank you for testing! :slight_smile:

4 Likes

[if there is a better place for test feedbacks, let me know]

The good thing: the load error dialogs I had with the previous APK are now gone.

The less good thing: trying to open any file (.kra, .png, .jpg), no error message, but no loading either.
Any log / additional test I can run?

EDIT:

  • I did check the permissions, the only permission (access to the storage) is granted.
  • I restarted the tablet fully, to no avail.

Thank you for reporting, it was a missing function which must have fallen through the seams while back porting. :slight_smile:

2 Likes

I might have the same problem as you. I open a file and it seems like it doesn’t load anything, but then I rotate the device or select a brush on the toolbar, and the screen refreshes, and the file is suddenly there, open and ready for work.

1 Like

Here are some observations I noticed in the build from this link

-Toolbox docker: Cannot select a tool with finger-click. But it does respond to finger scrolling if you thin the docker into a column thats 1 icon wide.

-Layer docker: You cannot toggle the visibility of a layer on or off when trying to finger-click the eye icon. Behavior is normal with a mouse or S-Pen.

Brush Preset History docker: When selecting a brush with the finger, your brush preset will not actually change to the selected brush, even though the chosen brush in the Brush Preset History docker becomes highlighted in blue. Behavior is normal when using a bluetooth mouse or Samsung S-Pen.

Keyboard Shortcuts: 1) This menu does not respond to finger-clicks. 2) Attempting to create a shortcut involving modifier keys is glitchy. Apparently the same shortcut is entered multiple times. For example, inputting “Ctrl+H” inputs this shortcut twice. To enter a modifer shortcut “correctly just once,” input your modifer shortcut that enters itself multiple times. Then add a shortcut that already exists on another action. When the window prompts you to replace, cancel. Your original shortcut now appears to be entered “once” in the correct fasion. 3) Even after doing issue 2, attempting to save a shortcut involving modifer keys does not save.

1 Like

This problem (file loading but needing a pinch/zoom/rotate or other refrsh to show up) I knew from the previous APK (sorry, I should have mentioned it) so I initially though that was it.

But that one is different: there absolutely no reaction after selecting the file, Krita still displays the “New / Load / History / Welcome” screen and neither image zoom/rotate/pinch or device rotate have any (visible) effect.

I have updated the arm64 build link. You should get an error dialog now.

This shouldn’t happen again, did you try the recent APKs?

I am indeed getting the error dialog again (“The chosen file’s location etc.”).

I am also still unable to open any file. :slight_smile:

With this new APK canvas is black until i disable Canvas Graphics Acceleration. Re-enabling Canvas Graphics Acceleration doesn’t re-introduce the bug until i restart Krita.
edit: bug appears when i open my previous work but it doesn’t when i create new one.

I just installed the latest APK you have provided. The issue I was describing is indeed fixed. I cannot replicate the other described issue however. Opening .jpg and .kra files works just fine on my tablet.

This problem is a bit hard to debug, I’m afraid. It can be anything from a driver issue from your device’s manufacturer to a bug in our OpenGL ES code. I’d suggest you to specify your hardware, Android version, bit-depth, scaling mode and color profile (of the file causing black canvas).

However, I’m not sure if it’s best to post it here…

You can DM me here I suppose, or as @aaribaud@mastodon.art, or as aaribaud on Twitter.

I can provide the drawing in DM or on some file sharing service.

I am not an Android developer so I cannot tweak the APK code, but I am a dev nonetheless, so I should be able to build and test a custom APK to help debugging if this helps.

As to the device: Samsung Galaxy Tab S3 (SM-T820), One UI version: 1.1, Android version: 9, Security patch dated 2019-08-01.

I tried an hour or 2 so far and here is what I noticed:

Device: Galaxy Tab A10.1 with stylus 2016 version (64bit ARM processor)

4.3 version mentioned on top:

Bugs:

  • 64bit fails to install, 32bit works
  • S Pen stylus button does not work. I was able to disable the touch and use stylus only, but the button doesn’t work. It goes straigth to “Samsung’s Air Command” instead of what I hotkey.
  • I ran into an issue where the brush choices GUI became invisible, I could still pick the brush changes but I can’t see what I pick.
  • In portriat mode, I can’t see the OK button with opening up configure krita. This is probably because the tablet is 16:10 ratio instead of 4:3 maybe?

I’ve also tried the newer 4.2 build, and all the bugs were still there. (Though I have not used it long enough to see if the invisible brush gui still happens, I’ll see if I can find how I did it)

General Complaints:

  • The top navigation is a waste of space, I don’t mind clicking the 3 dots to get to the menu, but having just the logo there and the 3 buttons feels like it just uses up space.

  • The right menu with all the layers and tool options needs a minimum mode. It takes up a lot of space for no reason. I like it how other editors do it where you just see the layers as small boxes and when you click more, the whole thing pops up.

Effectively it would be nice to have a focus of being able to draw, change layers, change colors and brushes as a minimalist mode, then pressing a button would expand them to give finer controls.

That’s it for now, but overall I think you’ve done an excellent job!

1 Like

Previous APK doesn’t have such bug. My device is Huawei MediaPad M5 Lite (BAH2-L09). Android 8. Any scaling mode. I don’t know what my bit depth is, i didn’t change it. Here is an example of problematic file: James.kra

Thanks! I can reproduce this.

I found what code is making this happen. However, I can’t figure out why it doesn’t happen with my other files…