My pen's buttons are working incorrectly only in Krita after this update

This bug is weird and started to happen after the update 4.4.0, so sorry if there is a easy fix and I didn’t found it, but basically my pen’s button’s are incorrectly here, I thought it was my tablet config but it’s not, it works normally in other programs so the problem is only on Krita. I tried to change config in Krita but the problem continues, the sensivity still works normally, is just this button configuration for my pen that I want to let the way it was before

Hey, can you check if the following gelps? Go to settings->configure Krita->tablet, select ‘wintab’, press ok, and then restart krita.

For what it’s worth, the only shortcut related bugfix this release had was this one.

So the thing is that it’s already with ‘wintab’ and I changed again and restarted to change to ‘wintab’ again and the problem continues. All the others shortcuts still works normally, is just the pen buttons

and if you switch to winink?

I did that and the problem just changes, then one of the buttons doesn’t work

Ok update here: There is a option called ‘‘Use mouse events for right- and middle-clicks’’ that seems to fix my problem, I don’t know if it is a new option but it fixed my problem

So yeah if anyone have the same problem was mine you just check this option.

1 Like

Thank you, this is SUPER HELPFUL!

Can you clarify that you are using winink+use mouse events? Or is it wintab+use mouse events?

wintab+use mouse events, but it ‘‘kinda’’ fixed my problem, but still now the other button I used doesn’t work too lol, so yeah it kinda fixed it. I just got back to the older version that doesn’t have this problem. Maybe there is a actual fix for this, but I didn’t saw anything about it

Well, that’s the thing, I’m a dev and I was discussing this with another dev, and we are kinda confused what is going on, as noone reported this during the betas, yet we have seen reports on reddit as well since the formal release. So we’re trying to figure out what causes it.

Thing is, that checkbox isn’t supossed to do anything when used with wintab, it only should work when used with winink, so the fact it actually change something for you when using wintab is super mysterious!

I don’t know if I can help but here’s some weird stuff I found about it:

  • This problem is only on the canvas, in the menu and stuff it still works normally

  • It doesn’t seem to have any option to change it, making me think that maybe it’s a bug

  • Aside from the mouse option, it stays the same even if I totally change the config in Krita or even in my tablet

  • The buttons are in default for moving for one and that color choosing thing that I forgot the name for the other

  • Even if I reset the program configuration or put the old one from the older version this problem continues

So yeah I hope I helped in something, I still can draw normally, it’s just that I prefer my config for my pen instead of this one.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.