Pen pressure and middle mouse don't work at the same time

Hello, I’ve been trying to solve this for a few days and finally decided to make a forum post because I just can’t solve it.

Info:
Tablet: VEIKK A30
Sofware: Krita 4.3.0
Driver: VEIKK driver for windows
OS: Windows 10 64-bit

When I first opened Krita after downloading it, my pen’s pressure worked fine. This is my first time using this software, so after watching a couple videos and reading some stuff I realized mapping my middle click to one of my pen’s buttons would be useful for manipulating my canvas. I go into my driver software for my tablet and map my pens 1st (top) button to middle click. I then go into Krita and attempt to use it, nothing happens. I close Krita and attempt to use the pen button to activate middle click in my browser, it works.

I look up this issue and find only a couple posts many years old with a few solutions that didn’t seem to work. I reinstall my driver and Krita, still have the same problem. I then start to mess around with my input setting. I start by going into canvas input setting and trying to map the input to my first pen button. When I press my pen button when it asks for input, it registers it as my middle mouse button. I go back to the canvas, but it still doesn’t work.

Next, I mess around in the tablet setting. I switch from the WinTab api to Windows 8 + pointer input (Windows ink) and restart Krita. Now Krita registers my middle mouse input but has stopped registering the pressure from my pen. I look at my driver software and notice that there is a “Enable Windows Ink Function” button. I press this and restart Krita. Now Krita does not register my pen at all including button inputs or pressure.

Finally, keeping windows ink function enabled in my driver I switch back over to the WinTab api and restart Krita. Krita recognizes my pen’s pressure input but still does not recognize my middle mouse input. This is the same as when I started.

It is probably worth noting that throughout this entire process using my actual mouse’s middle mouse button worked perfectly. Also, any other button I map to my pen such as right click, or a command sequence like ctrl+z work perfectly. I simple have a problem with Krita recognizing my pen’s middle mouse button input.

Any help and support is greatly appreciated, thanks in advance!

Edit:
After messing around with my tablet driver software just a little more I realized that actually any click I assign to my top pen button doesn’t work but command sequences do.

Also, anything I reassign my bottom, second button, does not work and Krita seems to override it with right click. It was already right click and I was fine with that, but I thought I might as well check.

Hello and welcome to the forum :slight_smile:

Do you want to assign a pen button to middle-click so you can grab and pan the canvas?
If so, the ‘space’ works for that with a pen.