Pen pressure not working in any way

Type of device* : Graphic tablet
Brand and version of the device: Xp-pen Star 03 Express Keys
System** : Windows 10


Description of the issue (you can include screenshots):
I’m trying to learn how to use Krita and I run into the issue of the pen pressure not working. I’ve looked up how to fix it, read the FAQ, and even skimmed through here and couldn’t find anything of use. I have Windows, Krita, and my tablet’s driver all up to date. And it works fine on Medibang. I have the Windows Ink selected on both the driver and Krita. It had worked a while ago when I first downloaded Krita in the summer. I have no idea what’s wrong and I could really use some help on this.

1 Like

When you say it’s “not working in any way”, do you mean that your painted strokes always have maximum opacity or size?

Have you ever tried activating the ‘Use Pen Pressure’ icon on the Toolbar or via a shortcut? If so, you may have turned pen pressure ‘off’ so that krita always uses maximum pressure, as if you were painting with a mouse.

In the Settings, can you try setting it to Wintab and disabling Windows Ink options in your tablet setup/config utility?

If it worked when you first downloaded krita last summer then something has been changed, either in krita settings, tablet settings or maybe a driver update or a Windows update. Windows updates have been known to break various things including tablet drivers.
As far as I’m aware, there has been no change in tablet interface related code within krita.

In Settings → Configure Krita → Tablet settings, try the Tablet Tester and draw on the grid area and see if you get pressure signal (P=xy.z%) variation over the full range.

It should also be mentioned that not all default brush presets in Krita support pressure. A common mistake for beginners is having a brush selected that simply doesn’t have pressure.

Ah, I didn’t know that, thank you!

This fixed the issue, thanks!

Having the same problem. These steps are not addressing the issue. Surface pro 7 with brand new surface pen. It works in all other apps I’ve tried. I’ve gone through several brushes, Uninstaller/reinstalled… and I’m out of ideas.

It might be a good idea to make a new topic, since your device is different.

Done. Thanks for the heads up.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.