Pressure isn't detected

Type of device* : Surface pen
Brand and version of the device: Surface pro 7/surface pen
System** : Win10


I can’t get a pressure response (always max) in krita. Everything works fine in other programs. I’ve successfully turned on "use pen pressure, tried wintab and win8+, uninstalled/reinstalled, rebooted, checked update…I’m out of ideas.

Edit: Tried switching back and forth with wintab/win8+ again, and playing with the pressure curve settings, after fiddling with surface app and paint3D and the problem resolved itself.

Is that the settings of the S-Pen at the Windows settings level?
That is probably what did it.

In all cases like this, it’s the incorrect matching of krita’s setting, i.e. Wintab or Windows Ink compared to the settings in the tablet (of whatever type and form).
Also, some tablets have fancy things like Gestures, Flicks, Finger touch, application specific profiles, a need for a PC restart after any changes - any of which can cause problems. Then there’s the breakage caused by Windows updates which needs a reinstallation of the tablet driver to get it working again - and that needs to be done according to a specific sequence of actions.

The pressure curve settings etc inside krita are set up to work properly on first installation and do not need changing in any way.
Uninstaling and reinstalling krita will not fix anything except in the very rare circumstance where the hard drive is starting to die, in which case there will be far more serious problems to deal with in the near future.

hi, i’ve a surface pro 7 too and Raphael pen, you have to use windows ink in Krita to have pressure sensitivity working (and restart Krita after changing this setting). I also installed ‘surface’ app from the Microsoft store to setup the pressure curve

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.