Problems with a Brush

Heey! I’ve been using Krita for a few weeks, all the brushes work, but yesterday the brushes that simulate watercolor don’t work. When a select, for example the brush _WaterC_Spread _WideArea, don’t paint anything in the layers. I try somethings, like close and open the app again, but the problem continue, Can someone help me or know the problem?

1 Like

Is this a problem with water color brushes or all the brushes? Do you have erase mode on?

Only with the water color brushes, when I pick another brush work perfectly. I don’t have erase mode on

Is this with all watercolour brushes or just some?
Some of those watercolour brushes don’t put paint down at maximum pressure or when using a mouse.
Does Watercolour Fringe work or Watercolour Texture? (They do put paint down at maximum pressure or when using a mouse.)

I have this same issue. I came here to post the same question. Since downloading the new watercolor brushes with Krita 4.3 those new watercolor brushes don’t work. They are very light, barely visible, or don’t show up at all. And there is a lag between when I make the stroke with my drawing pen and when anything (if anything) shows up on the canvas. I am drawing using a drawing tablet, and it is as though I have the opacity wayyyy down when I try to use the brushes (but the opacity is not down, and all the other brushes work normally). When I open the brush preview/scratchpad in the brush settings the watercolor brushes work beautifully, it is only when I draw on the canvas that it doesn’t work. I’ve tried everything, all different settings, all different canvases and layers.
I should add that I’ve been using Krita for almost a year, and haven’t had this issue with other brushes. :slight_smile:

1 Like

@Anita_Gasalla @rem you can download new versions of those brushes from the description of this video:

Direct link: https://files.kde.org/krita/extras/WATERC%20stylus%20and%20mouse.zip (but do check the video too!)

1 Like

That brushes that you said work. These are the brushes that don’t work, I think it’s important to clarify that I only tried the watercolor brushes, and that I had already used these brushes before and they worked perfectly. Also I tried with a graphic tablet.

Thanks you!! This really work, if I ever have this problem again, will I download / reinstall these brushes?

No, they should have proper settings now. They will be included in the proper settings version in the 4.3.1 version, too. Hopefully you won’t have this problem anymore.

1 Like

I tried downloading the brushes from the link you shared, and opened the Zipped file, but now they aren’t showing up when I try to add them using the Manage Resources window. In the Krita Manual it talks about .bundle files but these have a .kpp file ending. How do we add these updated brushes to Krita?

.kpp files can be imported with “import brush presets” instead of “import bundles” button.
You can also use “open resource folder” find the “paintopresets” folder and place .kpp files there

Thanks for trying to figure this out with me. When I go to the Manage Resources window, nothing shows up in the unzipped folder with the brushes. They are all there when I open the file in Finder (Mac), but the file is empty when viewed in the Manage Resources window in Krita. I’ve had this issue before when icloud sneakily uploads files to the cloud and then they don’t show up when I try to open them from Krita, but these brush files are not being uploaded to the cloud.

They’re not brushes, they’re presets so you need to ‘Import Presets’ in the resource manager window.
It may be less confusing to just manually copy them into the resources folder paintoppresets folder.

I think the labelling could be improved to make it less confusing; the brush editor uses ‘brush tip’, but in resources (and the folder) it’s just ‘brushes’. :thinking:

yeah, that’s because we used to be able to read the resource folder of gimp and other graphics programs, where the brush tips are also stored in the brushes folder.

1 Like

Maybe screenshots will help show what I’m seeing.
First, the brush presets in my downloads folder:

And then the Manage Resources window and nothing showing up:


As you can see, the ‘import presets’ function doesn’t make the watercolor brush presets show up, and they don’t show up no matter what I select, or type in the file name box.

A few people have mentioned the painttopresets folder, could someone please share screenshots of what/where that can be found? I can’t find anything helpful about it in the Krita manual or blogs. (Nothing that shows up in the most updated version of Krita anyway).

In the resources window you’ve got open above, there is a button at the bottom of the row of buttons labelled ‘open resources folder’. If you click on that it should open the Krita folder containing numerous other folders - one of which is the ‘paintoppresets’.

Okay, I found the painttopresets folder and copied the brushes over. Then I only had a few brushes, and the watercolor brushes all showed up but with an X next to each brush icon. So I reinstalled Krita 4.3, and now I have a different set of a few brushes (not as many as it should have) with icons I’ve never seen before.
:expressionless: I just want to draw!!

new brush presets??|261x203

How do I erase everything and start over? I will just not use the watercolor brushes if I can get all the full selection of old brushes I’m used to back.

I downloaded that collection of Watercolour brush presets, as linked to above by @tiar, then I unzipped the file and copied the .kpp files to the paintoppresets folder and restarted krita. As a result, I had Watercolour brush presets that all painted with a mouse.

Reinstalling kita will have no effect at all because it stores its configuration files and its resources in an area not affected by the installation process. In this way you can update to a new version and keep your configuration and resources.

If there’s an X next to the brush preset icon, that means it can’t find the brush (tip) that it’s supposed to use. The image you posted shows the brush presets that have the ‘Sketch’ tag, because you’ve selected that tag in the drop down box at the top of the brush presets docker.
There should be more than that for the Sketch tag.

Have you disabled the Krita_4_Default_Resources bundle in the resources manager? That would explain a lot if you have.

If you really want to nuke it back to a fresh start you can do that easily.
Just delete the -/krita resources folder and start krita and it will be just like it was when you first started.
Not quite actually because you’ll still have your configuration and look/feel settings. To nuke those back to the start you have to delete the configuration files which are called ‘krita{something}’:
https://docs.krita.org/en/KritaFAQ.html?highlight=configuration#where-are-the-configuration-files-stored

Since it’s the resources that are giving you problems, I’d suggest nuking the resources folder only. That would also remove any personal brushes, brush presets, workspaces, palettes, patterns , etc that you may have made. A fresh start.

Thanks! I didn’t get a notification of your response but yes I basically deleted everything to do with Krita (I’ve only been using a year so I didn’t have a lot of personalized settings), and now it’s back to normal! Phew. AND the watercolor brushes work. Yay :slight_smile: