Rendering Issue?

When trying to render an animation ,the final outcome has a grey tone to it. Like the colour has been washed. Anyone know what could be causing this issue?

And if @MeltedInk is the same person that came on IRC today:

  • the document is sRGB, default profile etc.
  • the display isn’t fancy, most probably shows sRGB as well
  • PNG frames look correct
  • only the rendered video looks washed out.

I guess the follow up question is what the configuration in the render animation menu is like?

i think i got a pretty similar problem…have a solution already been found to this problem? My animation clip, too, is looking more grey when rendered. So I tried several different options, but non of them changed the outcome. :confused:

In the past, I’ve noticed that .mkv appears to have less contrast and be less saturated than .mp4 when played in the same (VLC) player.
As noted by wolthera, the exact configuraion and settings of the render animation menu need to be reported.
Another possibility is that the video player being used is having an effect. This can be checked by using a different video player since there are many free ones availalable.

thanks for your reply :slight_smile: . I posted screenshots of the configurations i had on last time…however…i tried to watch the animation in different players, but they looked all the same grey when playing. I am a totaaal noob concerning animations so i have no idea what some of the render configurations do :sweat_smile: :grimacing:

Your settings are the same as mine except for one detail:
It looks like you’re using the 20th February development build of ffmpeg. I’m not saying there is anything wrong with it but as a general principle you should only use the formal release for ‘normal’ work (unless you’re chasing new features or involved in bug fix/tracking work). You might want to try the formal release instead, just to make sure.
If that doesn’t help, if you post a download link to your .kra file and the rendered .mp4 file, I can try it on my computer to see what happens (but not for quite a few hours from now).

1 Like

thanks again for replying! I have a question: where do i find the formal release?

Here: https://ffmpeg.zeranoe.com/builds/
Click on Version 4.2.2, Architecture 64-bit (I assume), Linking Static
then Download it, etc.

ok. so…i downloaded it and tried rendering…unfortunatly it didn’t work. So I’m going to send it to you

It looks like KittyTaja has a local problem.
I have the .kra file and it’s ok with pure white lineart/lettering on a pure black background that changes to pure black lineart/lettering on a pure white background. RGB/A 8-bit sRGB built-in, nothing unusual to be seen anywhere.

In the .mp4 file, white is 48.62% grey and black is pure black.

I rendered the .kra file to .mp4 using ffmpeg 4.2.2 and I got perfect results on my Windows 10 system using krita version 4.2.8.

Can you do the following: Render out a small range of frames (I’d suggest 192 to 196) to an image sequence and look at the resulting .png files to see if they have the correct black/white levels.

Also, can you render the entire animation out to .mp4 and provide a download link to the log_encode.log file that is produced?

Also, can you download this animation:
https://www.dropbox.com/s/tpptl9j4cfpb0kg/moving-circles.kra?dl=1
Render it to .mp4 and provide a download link to the resulting .mp4 file?

You need to go to “Both” tab in the Render Animation dialog and then go to PNG image sequence option and make sure “HDR” option is unchecked, and then go to the mp4 or other video format options ([…] button) and again, make sure the “HDR” option is unchecked. If it still doesn’t work, please do this:

  • render as Image Sequence and check if the images are saturated or not,
  • go to the folder you render it to, open log_encode.log file, go to pastebin.com and copy everything there an share a link,
  • go to Settings -> Dockers -> Log Viewer, find the log Viewer docker, press the first button to make sure logging is enabled, then try to render the video again. In the Log Viewer there will come some text, please copy it and either paste on pastebin.com or paste here directly (if it’s short).
1 Like

ok. I did render the range of frames (192 - 196) as png and they all where in the right colour tones: black and white xD…it seems that rendering it only as pic is ok…but when rendering as clip, then it gets grey. Btw I updated my Krita from 4.2.2 to 4.2.8, unfortunatly without same result as you.

Here is the link for the log-file:

I dont know why, but it seems that the colours for this animation stayed as bright as in the original.
I put down below the link for the rendered version and the log-file (if needed):


UPDATE: it finally worked! xD

I did render it both and unchecked the HDR option and yeah.
:smiley:

Here is the final result:

Thank you both SOOO MUCH for helping (@tiar and @AhabGreybeard )!!!
I don’t know what I would have done without your support :smiley:

1 Like

The moving-circles animation uses the RGB/Alpha (8-bit integer/channel) sRGB-elle-V2-srgbtrc.icc colour profile, not sRGB built-in.
I’ve no idea why that should affect things but perhaps try that one in future?

I’m glad you’ve got it working now and I’m sure we’re all looking forward to seeing any animations you produce, especially after such a promising introductory animation :slight_smile:

1 Like

Nah, it shouldn’t, those two profiles are very similar to each other.

In any case, I think it is because of the HDR option because I had a few cases like that already on reddit. I made two wish/bug reports: https://bugs.kde.org/show_bug.cgi?id=417521 and https://bugs.kde.org/show_bug.cgi?id=416772 , hopefully before 4.2.10 or 4.3.0 someone will code this because I believe it’s quite important, considering already a few people got hurt by those options, which are quite vital but hidden away.

Yes, you’re right: I can induce that condition with the moving-circles animation as follows:
Render to Both and set Save as HDR Image to checked, then render.
From that point on, rendering to Video shows reduced brightness.
Recover by rendering to Both and set the HDR to unchecked.

I’ve never set that option before or even paid attention to it so maybe that’s why it never happened to me.

1 Like