Sketch Tablet - Minimum Stroke Length

Device: Tablet (Non-Screen)
Brand and Version: Wacom INTUOS - CTH-480
System: Windows 10


It’s simple, really; in order to ensure Krita registers a stroke (and not a long-press), I need to zoom in so my intended stroke fulfils the arbitrary minimum length requirement. This is a non-issue for finer work, like the artwork members on this forum produce - but I mainly use this software to doodle and write notes, mostly zoomed out so 1/4 of a 600D/PPI A3 is visible on-screen.

Zooming is an acceptable workaround to this problem, but it has a pretty significant impact on how much work I can get done in one session, believe it or not. I’ve gone through the settings once or twice to see if I can find one aptly named enough to establish it as the cause of my issue (minimum input, move, distance, length, stroke, et cet.) but I’m yet to track it down.

Could anyone point me in the right direction? I want to make it shorter, but not abysmally short, as I don’t want it causing difficulties with the long-press tooltip (very, very convenient) - there should be a setting for it, somewhere, that won’t require me to edit and build from source.

I’ve ruled out my hardware - GIMP, Inkscape, Blender, et cet. all register my strokes roughly the same way when using my tablet. It’s relatively unaged, and quite the workhorse.

Lastly, I don’t doubt Krita gets a flood of praise here, but I’m quite impressed with the suite as a whole. I’ve not needed a raster alternative for some years, that is until now; very glad a quick search sent me in the right direction.

This sounds weird. It should make no difference how long you put the pen on the tablet it should always paint. I have no issues making a stroke one pixel or hundred pixels in length. The only thing I could imagine causing your issue is when you have a stabilizer on (called smoothing in Krita) and it’s set to high. You wrote you mostly write notes so you could safely turn stabilizers off.

Here’s the manual entry about smoothing

You find the setting in the tool options docker.

That sounds as if it was Windows interferring. Krita doesn’t do any “long-press” stuff, it’s all Windows. (Krita by default shows the popup on right-click; and probably Windows by default converts long press to right-click…). Check Pen & Touch settings, there are usually those “flicks” and “gestures” defined there. You can also switch Krita to Windows Ink and restart your PC, that usually fixes it, too.

1 Like

I think someone else may be having this problem:

Another thing to keep in mind when people have tablet problems.
So many things to keep in mind :slight_smile:

Thank you for taking the time to respond; I appreciate it.

Within the link to the manual, there do seem to be parameters that affect Krita in the way I suspected (this is a sub-parameter mentioned in the manual, I need to confirm it’s there in-app):


The distance the brush needs to move before the first dab is drawn. (Literally the amount of events received by the tablet before the first dab is drawn.)"

I really love the long-press tooltip, I fear disabling “smoothing” altogether might make the tooltip inaccessible without shortcuts. I’m going to test and confirm, however, nothing gained by speculating.

Thanks again!

Thank you for taking the time to respond!

My stylus does have two adjacent buttons meant for that, as well as a flipped eraser to quick-switch to the tool; but I’ve generally had issues with these (sometimes needing to manually map them), so I’ve grown used to the single input (tip). The tablet itself has four additional buttons (nice big ones, for big fingers), but these generally cause the same issues, so I work around them too.

On that note; does Krita support custom mapped input?

Ah! No forum is complete without a cynic or two. I’m one myself; already right at home.

hi, so Ahab brought me over to this thread with that repost and I’ve been trying to figure out a solution from everything over here, and I’m not really sure where to find these settings. I can only find these two places that would seem to have a solution pen and windows ink settings, on my computer, and tablet settings on krita, and I don’t see the settings you are talking about on either. i also cant figure out how switching krita to windows ink works to try that.

If you’re on Windows, go to (in Krita) Settings → Configure Krita → Tablet Settings ->, switch to Windows Ink and restart Krita. For the other settings, they are somewhere in Windows Settings, but I’m not 100% sure where exactly since I’m not on Windows right now. You need to search for it yourself, sorry.

1 Like

that solved the problem, thank you very much. nice bonus the pressure sensitivity works now too so that’s cool. sorry about that it probably shouldn’t have needed explaining, I just saw the windows 8 part, thought oh that’s old probably don’t want that, and missed the windows ink part. again thanks for that, excited to start using this.

1 Like

That has solved it; thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.