Solved - Kriti 5.0.6 - Doesn't open - 'Could not initialize the resource cache database.'


I have not opened Krita in months and this is the error that pops up if I open it up, I was messing with Krita a few months ago and made a mistake which then made this error pop up, at the time I did have an idea of how to fix it or undo my mistake but I procrastinated on it and here I am months later where I don’t even remember what I was messing about with, I believe I was messing with something related to the new recorder docker but unfortunately I do not remember very well what I was doing with it.

I use Windows 11 and have prior worked on Krita while having Windows 11 installed on the system without any issues.
I have re-installed Krita 2-3 times but the error still pops up.
The laptop I work on is a Dell Intel Core i5 8-Gen with integrated graphics with 8 gigs of ram, I have had a wonderful experience using Krita from the last 2 years on this device.

I apologize that I do not remember anymore details to make your work easier, Thankyou.

Try this. Make sure Krita is not running. Find your kritarc file and rename it (kritarc-old). Now start Krita.

(Where is the kritarc file?
C: Users - yourname - AppData - Local

Make sure your system is set to show hidden files. )

3 Likes

I did it and it worked instantly!

Thank you very much, I had been struggling with this error a lot. Hope you have a good day.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.