Can't change opacity while "V" holding Line shortcut

Holding “V” to temporarily use the Line tool with a Brush selected results in this somewhat comical behavior when then trying to change the opacity of the line. The brush’s opacity is 24%. I want the line to also be 24% but when the mouse hovers of it, it shows the opacity for the brush, so I can’t change the Line’s opacity from 100% down to 24%. It’s like a game of keep away: as soon as I’m about to do the thing I want the program prevents me from doing so. The workaround is to select the Line tool directly instead of holding “V”, but this behavior is counterintuitive.

1 Like

Probably best way to fix is just preserve Opacity of the brush when using temporary line “V”? That’s almost always what I want, at least for my use cases.

The behaviour of the ‘V’ key here is determined by the
Settings -> Configure Krita -> Canvas Input Settings -> Tool Invocation

These are only active when the cursor is on the canvas.
I suspect that most people would want the temporary line tool to be the same opacity as the brush tool when using the line tool in this way but I’ve no idea how difficult it would be to make that change.

You can propose the change in a topic here, for comment to get feedback.
The next stage (depending on feedback) would be to put a formal Wishlist bug report in at: https://bugs.kde.org/
That would then join the queue of very many current Wishlist bug reports.

If you change the lines tool opacity to 24 and then go back to the free hand tool and press v shortcut do still get that weird behaviour?

The next stage (depending on feedback) would be to put a formal Wishlist bug report in at: https://bugs.kde.org/
That would then join the queue of very many current Wishlist bug reports.

Thanks I’ll consider it.

If you change the lines tool opacity to 24 and then go back to the free hand tool and press v shortcut do still get that weird behaviour?

As mentioned in OP, yes, that works, but it’s a bad workflow and counterintuitive at least for my use cases.

It would be better to write about this particular issue here: https://phabricator.kde.org/T13347 since it’s related.