Expanding Spacer - Is it an Display error or a (minor) bug?

I’m sorry that the first topic I create on Krita-Artists is about something that is not working as expected.

Is it a security problem? I would say NO!
It is a flaw, a beauty bug in my eyes. :frowning:
(A workaround would be to fill the empty spaces with useful shortcuts) :wink:

Okay, here we go!
Trying last night to customize the toolbars “mainToolBar” and “BrushesAndStuff”, in Krita 4.4.3 under Windows 10, to my needs, the result was “unexpected”.
For a reason that is not clear to me, two of the four available “Expanding Spacers” are not “displayed visually”, but “in writing”, i.e. they do not fulfill their function as expected by occupying “space”, no, these two “Expanding Spacers” are displayed as words written out.

In this way, the elements to be separated are also “somehow” brought apart, but not as intended.

Since it was about 3 a.m., I decided to go to bed first to get to the bottom of it the next morning.

The following versions were tested

  1. windows 10:
    . Krita 4.4.3 - Portable
    . Krita 5.0.0-prealpha (git 7fbe819) - Portable
    . Krita 5.0.0-prealpha (git c4e3b84) - Portable
    . Krita 4.4.5 - Portable
  2. SUSE Linux Tumbleweed
    . Krita 4.4.3 (installed via package management)
    . Krita-5.0.0-prealpha-607fca8-x86_64 (AppImage)

To see if this behavior made it into the upcoming Krita 5 release, I filled the toolbars in yesterday’s version, Krita 5.0.0-prealpha (git 7fbe819), as a test, and this display error exists there as well.

Then this morning I waited for the build of the latest Krita 5.0.0-prealpha (git c4e3b84) and tested it with the same result.

Oops, yesterday Krita 4.4.5 was released, just tested it and added it here - error still exists.

Afterwards I did the test on SUSE Linux Tumbleweed with Krita 4.4.3, installed via the package management YAST, also the same display error. Finally I downloaded the newest AppImage Krita-5.0.0-prealpha-607fca8-x86_64 and there it occurs too.

To show the above described display error I have created corresponding screenshots.

  1. Expanding Spacer - Krita 4.4.3; Windows 10

  2. Expanding Spacer - Krita 5.0.0-prealpha (git c4e3b84); Windows 10

  3. Expanding Spacer - Krita 5.0.0-prealpha (git c4e3b84); Windows 10

  4. Expanding Spacer - Krita 4.4.5; Windows 10

  5. Expanding Spacer - Krita-5.0.0-prealpha-607fca8-x86_64.appimage; SUSE Tumbleweed

  6. Expanding Spacer - Krita 4.4.3 (‘Standard-Installation’ with YAST); SUSE Tumbleweed

So that was it, it’s not an error that would prevent anyone but me from painting or resulted in the loss of work. And that’s only for the time that went into testing, researching and creating this topic.

If this requires a bug report, I hereby ask that someone do it for me - if it is required at all.
I do have a KDE community account, but unfortunately I’m not familiar with issue reporting on KDE, nor with Bugzilla (and the KDE bug tracking system (bugs.kde.org) doesn’t accept my “KDE-Invent-Account”).
I tried to read into it today, but due to my limited capability, I feel overwhelmed with it at the moment.

Michelist

Then I hope I haven’t overlooked anything, or made a gross mistake in creating my first topic.
I translated and corrected this text using the DeepL dictionaries. It is not machine translated.

3 Likes

Reported: 438435 – Expanding Spacer items on the Toolbar sometimes shows words, not a space

You never forget your first bug report on the bug reporting forum.
There’s the confusion, the uncertainty, the nervousness and the excitement.
Then there’s the amazement that you actually managed to make one.
Then you notice the spelling mistake and you can’t edit it! :frowning:

3 Likes

@AhabGreybeard Thank you very much.

OFF TOPIC, TL,DR (just a very personal view of things.)

Making mistakes is human and I have no problem with that for me. But yesterday, after this report had already consumed some energy, after about an hour of reading on the pages of the KDE project, I got visual disturbances and a serious headache, because I didn’t want to make a big mess, I decided that it was enough now.
Because of my strokes I’m just limited, that’s stupid but not a problem and can’t be changed, I can always just see that I make the best out of it.
I will register on bugs.kde.org and in the coming weeks I will also learn the KDE bug tracking system to be able to submit bug reports myself in the future and also make “my mistakes” there.
If in doubt, I’ll have to ask some questions either on KDE or here on Krita-Artists.

Michelist

1 Like

Do you need to edit the title or the comment. The title can be edited but not the comment. :slight_smile:

2 Likes

It’s in the comment. My stiff and clumsy fingers do wrong or badly coordinated key presses then my brain auto-corrects what I read.

You’re welcome. After all the work you did in the topic here there wasn’t much for me to do really. I have experience of the bug reporting forum so I’ve climbed the initial ‘wall’ of comprehension and I know what to do.

It is quite clumsy and very unintuitive in places, especially for adding attachments, but you do get used to it. Whatever you do, don’t stress yourself about it and learn it slowly if you want to learn it at all.

For a long and complicated bug report, I type it out in a text file first (and try to get the spelling right) then when I’m satisfied I copy-paste the text file contents into the Description/Comment box.

If you have any questions or confusion you can ask about it here, maybe in a Lounge topic.

1 Like

This is the way I create larger texts for the forum, first writing them down, then translating and error correcting and then posting. Before the strokes I spoke fluent English, today I am happy to be able to speak my native language again without stuttering. But in my head it works, that’s where I get things put together, so it takes a little longer, but I have all the time in the world.
Thank you for your explanations and all the encouraging words.

Michelist.

1 Like