Feedback from Youtube users testing Krita 5 Plus

This topic is for the brave people who wants to support Krita helping with bug hunting. So if you have found a weird behavior, crashes and that kind of things, this is your place. Be part of Krita 5 and help us to create the best release possible. Go bug hunters! go!

Steps:

  1. Hit the Reply in this thread and explain what is happening and in which context.

  2. Go to menu help/show krita logs for bug reports Copy the info that krita gives you in the window that appears and paste in you Reply in this thread.

  3. Go to menu help/show system information for bug reports Copy the info that krita gives you in the window that appears and paste in you Reply in this thread. Push the Blue reply button and…

  4. Done, you have helped the Krita team. :hugs:

4 Likes

For resource issues, it might be better to download Krita Plus build insyead of beta2 since it has some important fixes. Othee than that, yes, it would be really helpful :wink:

3 Likes

I tried exporting my new brush set as a bundle with Krita 5.0.0 beta2 Plus Build (from today) on Windows and it has similar issues as last time I tried. Many of the brushes turn into missing brush tips and 1px and some have their patterns missing. This only happens for some brushes. Is there a way I can help? I can provide the bundle and resources or maybe record the export and results?

Fix for that is pobably here: Fix saving to bundles (!1125) · Merge requests · Graphics / Krita · GitLab so not in Krita Plus yet

2 Likes

Ah, super! :grin: Great work! I’ll check the next beta that releases and make a sound if the problem persist.
Thank you

The idea is to polish Krita as much as we can before the final release :D. so thanks.

2 Likes

I’ve reported a bug here: 443700 – recorder broken; each session gets separate folder, and cannot output full video … recorder only exports current session’s work, so it’s not possible to export a full recording. Am running Linux Mint Mate 20.2.

Concerning, as the appimage I was using back in July had been working fine, but I’ve just tested that, after the beta2, and it no longer works. Also, had Sparkylinux (rolling, Mate, debian-based) on the laptop, so I tried there … same result.

Had enabled logging in the beta2, but log showed nothing about recorder, or about crash.

Worried with testing 2 different appimages, across 2 different distros, and 2 different kernels, with same outcome, means it’s something to do with the system … webkit/wayland stuff? kernel? systemd/structural changes? I’m not tech-minded,only have noticed these things being worked on, so don’t really know. Chose Mate also to stay away from wayland etc as much as possible, lol, as it’s concerning incase art or anything graphics/art-related keeps breaking when xorg is already stable for art. Worrying if not only recorder exports, but other things also, start to be affected.

2 Likes

Try downloading Krita Plus version, does it work fine?

The recorder is probably a bug in the code, not a system issue.

Wayland is not ready for digital drawing yet so we don’t concerns ourselves with it much, except for stuff like being interested in the meeting about it that happened a few days ago. Krita’s goal os still Xorg for now.

1 Like

Thanks @tiar :slight_smile: I’m just downloading it now, and very relieved to hear the bug isn’t likely to be a system issue, and also about xorg being focal. Great to know that future Krita’s about bringing in only what’s properly workable. That’s awesome.

EDIT: I’ve tried the appimage, and unfortunately the same is happening.

Speaking of that, is there any plans for beta 3? I think it makes sense to release a new beta every 2 weeks or so regardless. Cause a lot of things may end up untested as less people try nightlies vs the betas.

2 Likes

Releasing is not that easy to do it every two weeks especially when the team is already pretty tired and somewhat understaffed (last week, both halla and dmitry were not working). I hope we’ll make beta3, last beta before the release, with no known regressions

5 Likes

Hey, I’ m using last krita 5.0 plus (beta2-84eaf3c867) on windows 10, I could not found LUT Management docker in dockers list, is that a bug?

2 Likes

Yes, I reported it here: 444912 – No "LUT Management" docker in latest stable appimages , thank you very much for mentioning it!

1 Like

Good point, because LUT docker can be used to see your artwork in greyscale and color in another view. Useful to compare tonal value if needed. :slight_smile: Thanks

It’s already fixed, and will be in the next nightly build from the 5.0 branch.

I’d seen there’d been a couple of recorder fixes, one being bringing in master, so tried krita-5.1.0-prealpha-5214230-x86_64 yesterday. Have today tried the latest Plus too.
Just incase that was the fix for the bug report, unfortunately it’s still not working.

EDIT: I’d said here that I was having issues with PSD recording, but had made a mistake in the bug report in not saying PSD being used … KRA recording works fine!

I’ve tested the latest nightly of Krita Plus and found that there’s still a bug concerning loading the correct texture pattern with some brushes. But I think I’ve found the problem! The patterns

(4-paper-soft-grain_testdark-black55.png)(280x280)
(4-paper-soft-grain_testdark-black15.png)(280x280)
(4-paper-soft-grain_testtweak2.png)(280x280)

appear to be missing from Krita 5. I can’t find them when I search for them in Krita 5 or from the resource folder. Maybe that’s why the brushes couldn’t either load any pattern or automatically reset to 01_canvas.png, the first pattern indexed in Krita

In the latest nightly plus, when I select these brushes no texture loads. The .png next to it is the pattern it’s suppose to load

f) Dry roller - (4-paper-soft-grain_testdark-black55.png)(280x280)
h) chalk details - (4-paper-soft-grain_testdark-black15.png)(280x280)
g) Dry Brushing - (4-paper-soft-grain_testtweak2.png)(280x280)
k) Blender textured Soft - (4-paper-soft-grain_testdark-black55.png)

The brush “y)Texture wood fiber” appears to load the correct texture(4-paper-soft-grain_testdark-black15.png), but editing any attribute of the brush causes the texture to reset to 01_canvas.png

The brush y)Texture Reptile uses none of the those patterns but for some reason it lags and resets to 01_canvas.png when editing any attribute of it. Selecting 22_texture-repile.png fixes the lag

Something weird I discovered about using these brushes in Krita 4 is that none of these missing textures will appear in Krita 4, until I select the brush that uses the texture. Then the texture appears in the program

The gif explains it better

papertextures

1 Like

I am finally testing Krita 5 Beta (Plus) and, first of all, CONGRATULATIONS! Fantastic update! Can’t wait for it to drop :slight_smile:

I found a couple of minor issues so far:

  1. Onion Skin has some minor artifacts

  2. The Timeline doesn’t have the ‘lock’ icon

  3. I cannot select multiple layers on the timeline with Shift+Left Click

  4. When you have a Set Start/End Time selection on the timeline, the playback skips random frames

Thanks!!!

@oliver I’ve just tried the Nov 23 5.0.0-beta2-03c30c6 appimage on Debian 10.

  1. I don’t see onion skin artifacts after making a similar animation to yours.
    I assume you don’t see them if using 4.4.8.

  2. The Timeline does have a ‘lock’ icon on each layer and it works.

  3. I can’t select multiple layers on the Timeline but I can’t do that with 4.4.8.
    Is 5.0.0 supposed to be able to do that?

  4. Setting Start Time to 1 (instead of 0) doesn’t give that problem for me for a short (4 frame) animation.
    Does it happen for any particular values of Start/End time and any particular Frame Rate or length of animation? (I used a frame rate of 10 or less so I could see and distinguish the frames as they appeared.)

@AhabGreybeard

  1. I don’t see them on 4.4.7 (the previous version I had installed)

  2. I mean the Timeline lock icon (not the layers lock)

  3. I can select multiple layers with shift+ left click on OSX (4.4.7). In the 5 beta, whenever I try to do that, it gives a visual glitch and don’t select any frame

  4. I’ve tried to replicate and seems to happen when I create a new frame between 2 existent frames (as if the cache didn’t recognise the newly added frame). I suspected the Drop Frame (to preserve playback) but I think it has nothing to do with it. Ah, and I have ‘Autokey Blank’ on.

  5. If I try to save a workspace with the dockers locked, whenever I invoke that saved workspace the dockers unlock