Issue with ffmpeg installation, render animation option in file is greyed out

I’ve installed ffmpeg with relative ease before, but I’m having trouble this time. I’m sure it’s something silly that I’m just overlooking but I’d appreciate some assistance since I’ve hit a wall. :sweat_smile:

Some info,
OS: Windows 10
Version: 4.2.7.1

I’ve been following the guide in the doc here and it’s been smooth up until the “Step 2 - Unzipping and Linking to Krita” part.
It says to go to File>Render Animation in Krita to link ffmpeg once you’ve extracted it, but for me that option in my menu is completely greyed out.
Is there somewhere else I can go within krita to get that linked up instead, or perhaps I’ve got my versions mixed up?

Hello and welcome to the forum :slight_smile:

EDIT:Correction: I MEANT 4.4.8 :blush:
I suggest that you upgrade to version 4.4.8. That is the latest version and has bug fixes compared to version 4.2.7.1.

The File → Render Animation item is greyed out if you do not have an animation open in krita.
So, do you have an animated .kra file open?
You can easily make one by creating a blank frame on the Timeline.

Ah that worked, thank you!
I tried opening a previous animation I had done, but since ffmpeg wasn’t installed it didn’t import properly and as such didn’t have animation frames within it to unlock that option. :upside_down_face:
It’s been a bit so updating is a good idea. Thanks again!

1 Like

As always with troubleshooting, one thing fixed, another issue crops up haha
My issue is tangentially related, so should I ask here or would it be better to start a new thread?

If it’s a different problem then a new topic is the best way to deal with it.

ffmpeg isn’t needed to open a .kra animation.
Were you trying to Import an .mp4?

EDIT:ADD: Please note my correction to an earlier reply regarding version number (it should be 4.4.8).

Off topic:
And I thought it was the FFmpeg version number and that you two were talking about FFmpeg-versions and had just wondered that there was an FFmpeg version that had the same version number of an older Krita version. :rofl:

Michelist

1 Like

I had exported it previously as a .gif
It was an old one so I lost the .kra of it

@Michelist The current ffmpeg release version is 4.4.1 so the numbers are confusingly close between ffmpeg and krita at the moment.

@Blushing_Sunrise Krita can’t import animated .gifs. They can be ‘cute and fun’ but are so full of .gif colour banding and sometimes dithering artifacts that they’re not at all useful as working documents.

1 Like

Oh I’m well aware, that’s what I was trying to say.
I saved the original document as a .gif just for sake of ease, and it was a while ago. It was my own work and something simple, not just something I found online, so artifacting wasn’t an issue.

To import animated gifs into krita, you need Krita 4.2+, you need to use a plugin:

Krita 5.0+ can import natively without any plugin.

This plugin is what I was intending to do right after installing ffmpeg lol
I wasn’t able to as the plugin wouldn’t launch and gives the error message that said it doesn’t recognize that ffmpeg is linked to Krita

You need to add the location for ffmpeg to the PATH env variable. Or find an ffmpeg version that has an installer and will put it in a place where it can be found in PATH.

https://www.architectryan.com/2018/03/17/add-to-the-path-on-windows-10/