Krita won't allow me to draw using my pen unless I start the stroke using the right click

Nov '24 - Hi, I just downloaded Krita v 5.1.3 onto Windows 10 (but have upgraded to windows 11 yet the problem persists) and draw using the screen of my windows laptop and the pen it came with. My problem is whenever I try to use the pen tool to draw, nothing happens. I can hover the pen above the screen and the brush indicator follows it fine but when I use the pen to draw nothing happens and the indicator won’t follow my brush. Things like changing colours or brush sizes works fine I just can’t use any tools as nothing happens. I have done nothing to the settings bar turning off hand drawing. however, if I use the right click button on my pen before touching the screen, it will work but only for that stroke. Any advice? thank you. : )

1 Like

Ignoring driver settings for a moment, are you left handed and have configured windows to switch right and left mouse button? This could perhaps confuse Krita when the tablet driver picks that up the wrong way qnd senda the wrong button presses to Krita.

Unfortunately, I am right-handed and haven’t configured anything for my pen so that is probably not the case.

Does a mouse work normally for drawing and does a mouse right-click activate the popup palette?
If you don’t have a mouse, does the tablet touchpad + left-click-hold draw normally and does the touchpad right-click actvate the popup palette?

In krita, do Settings → Configure Krita → Tablet Settings, then enable “Use mouse events for right and middle clicks”, then press ‘OK’ and then restart krita to see if that fixes it.

Is it set to use Wintab or Windows Ink?
Try changing the Wintab vs Windows Ink settings to swap one to the other, press ‘OK’ and see if that works.


Yes! thank you so much your solution worked! I enabled use mouse events for right and middle clicks and changed it from win tab to windows ink and it fixed it thank you so much!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.