My Pen does not draw on Krita

Hello! I recently returned to Krita after a long break, only to find that my pen doesn’t draw. I’d like to say first, that I’ve tried almost every possible solution I’ve seen, to no avail. De-selecting does not work, all my layers are unlocked and visible, I do not have any group layers (that I know of), and Krita does recognize my pen and knows it’s there. If it is any help, I can still draw in the scratchpad and tablet tester. I have also left most settings alone (besides changing the tablet input to Windows Ink and canvas acceleration to OpenGL). I appreciate any and all help, thank you!

Does it still not work when you create a new file? Does Krita register your pen when clicking buttons and stuff in Krita?

Yes, it still does not work when creating new files. I have yet to try if the pen is read when I click other buttons, as I usually use my mouse for that, but I can try later today. :smiley:

Take a look at the tablet tester, in the Krita settings, while you at it. Perhaps it gives some useful information too.

I can use the pen to click and access the buttons, and I don’t see anything wrong with the feedback from the tablet tester, which probably means it’s working perfectly fine.

It’s strange that you still can’t draw on the canvas itself.

Can you make a screenshot of whole Krita with a file open where you can’t draw? Maybe we can spot a setting gone awry or something.

I assume you tried different brushes already.

What kind of tablet do you have, what’s your Krita version?

I assume that you are using Windows from version 8.x upwards, all previous versions are no longer supported (even if they might still work)!

I would suggest, if you are familiar with the Windows file system and are not afraid of system folders, you download the portable version of Krita (this is a direct download link!) and unzip it to a directory of your choice.

Then go to your Windows user directory, in the path “c:\Users\{YOUR WINDOWS USERNAME}\AppData\Local\” look for the files “klanguageoverridesrc, kritadisplayrc, kritashortcutsrc, krita-scripterrc, kritarc” and move those files of them that exist to a backup directory of your choice, NOT ALL OF THESE FILES MUST EXIST, THAT DEPENDS ON YOUR SETTINGS.
The term {YOUR WINDOWS USERNAME} MUST be replaced with your Windows username, including the brackets.

If you don’t have access to the path “\AppData\Local” you have to unlock the view of hidden folders and files in Windows. How to do that you can find out here.

When you are done with this, you can start Krita with the shortcut Krita.lnk in the unzipped folder of the portable Krita. Then you have a “new” Krita installation without any default settings, like it was after the first installation. Can you use the canvas there now?

Michelist

My Krita version is 4.4.8 and my tablet is a Ugee M708. The Light Grey area on the screen is the canvas, and I can’t draw on it.

I’ll give this a try, thanks :smiley:

I can’t see anything wrong, maybe it’s something in the tool options of the Brush tool. Do other tools like the Line Tool work, or the selection tools? I don’t think it’s an issue with the tablet since it works on the scratch pad, as you wrote (although one never really knows).

Nope, the other tools don’t work.

Super weird. Just to double check, can you draw with the normal mouse on the canvas, without the Pen?

Can you upload a screenshot of the tablet tester after you’ve drawn a line on the grid area with the stylus?

Also, can you try it with Canvas Acceleration turned off?

If you’re returning from a long break, it’s possible that a Windows update has messed up your table driver and/or its configuration files.

Try uninstalling the existing driver then do a full power down restart.
Then check the Ugee website for the latest driver and install that in accordance with the instructions in the manual.

Nope. I tried that earlier today.

I’m currently taking a break right now, but I’ll try that when I decide to log back onto my laptop again :smiley:

I’ve looked through the Krita folder in AppData and I couldn’t find any of those files anywhere D:

Also, I checked the tablet tester: First screenshot is with acceleration on and second is off


Not in a “Krita” folder in AppData-somewhere but at the end of the “\AppData\Local\” folder, as it is written in my previous post, these files are not in a folder named Krita!

Michelist

Windows ink is probably the problem. The software doesn’t know if signals are coming from a graphics tablet or a touch screen. You should turn off windows in the the tablet properties app. Make sure Krita input device settings have wintab turned on.

ohhhh, okay. My bad. Yeah, that doesn’t work. I moved the portable you sent into a folder in my external hard drive, and tried opening the app from the application shortcut within the files. still the same issue.

I couldn’t find an option in the Tablet Settings to disable windows. I tried looking in the actual Ugee app, but despite my tablet being plugged in, it doesn’t see it, so I can’t enter that app. I have, however, turned the Tablet Input API back to WinTab.

I can think of one other possibility. Control panel, pen and touch, you’ll see a list of items with “press and hold” - “right click” at the bottom. Select that and click on settings. Uncheck “enable press and hold for right clicking.” It has been known to interfere with art apps because it interprets a pen touch on the tablet as a right click and prevents drawing. Just DON’T let anyone talk you into uninstalling and reinstalling your drivers. They aren’t your friends.