Pen isn't lining up

Type of device* : Laptop
Brand and version of the device: Lenovo Yoga 7i
System** : Windows 10

* graphics tablet/display tablet/2-in-1 laptop/Android tablet
** Windows/Linux/Mac/Android, + version (you’ll find it in Help -> Show system information for bug reports)


I have a Lenovo Yoga and a bamboo pen I use to draw, and when I opened Krita today. After having been using it with no problems major problems for weeks. It’s having a meltdown. Before today it would occasionally get laggy, and I mean really laggy.

The pen is offset from the curser, and I tried my pen on just the screen and it’s fine. But on Krita it’s not lined up at all. I tried uninstalling and reinstalling, uninstalling and redownloading the installer then reinstalling, and looking at the settings and I have no idea what’s wrong with it.

Tapping the screen gets this craziness, and using the mousepad works just fine. Please help me I have charter references to finish!

:persevere:

Hey, you can find a list of solution on the FAQ, tablet chapter: Krita FAQ — Krita Manual 4.4.0 documentation . Maybe something like enabling Windows Ink in Settings ‣ Configure Krita… ‣ Tablet could work for this model? Hard to tell without the model in hand.

I checked it out and this didn’t help. It’s a Lenovo Yoga 7 14itil5. It’s a laptop, not a tablet if it matters. I was able to use Krita on it without anything more than some lag before today so I’m not sure it’s a problem with the settings. I’m worried it could be a glitch.

I think uninstalling it and reinstalling it would have reset them.

Did you press the dual screen button or something like that?

Uninstalling and reinstalling krita will not make any changes at all.
The settings, configuration, look-feel, behaviour of krita is controlled by various configuration files and some contents of the resources folder. All these are separate from the installed application.

If you’re sure that you didn’t make any changes to the settings in krita, just before this started to happen then it can’t be a problem at the krita side. It must be something to do with the Lenovo or the Bamboo pen.
(Though a change in behaviour of the pen might be fixed by switching between Wintab and Windows Ink at the krita side.)

I don’t think so.

I already tried that, and the pen works just fine else where on the laptop.

Okay … I’m thoroughly confused. I was going though some of the settings looking for anything that might have been the cause of the problem and, after finding nothing that seemed right, decided to try the pen again. I worked, It’s just magically fixed it self or I somehow fixed it without knowing???

It may have been the windows ink setting after all.

In any case it’s working now! Thanks for the help guys! :grinning:

Thank you for sharing that your issue is solved. :+1:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.