Pop up pallete causing crash in krita 5.0.0

is this the intended minimum size for the selector and palette? because for me i cant go lower than these and its too large when i use the shortcut for the pop up palette, i cant access it and crashes the application

id like to know if the minimum size is intended because before krita 5.0 the pop up palette would smoothly pop up without crashing

Yes that is the intended minimum size, which is actually slightly smaller than the fixed value it had in 4.x.
If it got larger, it can only be due to changed settings for UI scaling.

No idea why it would be crashing though, but without even knowing the platform it’s impossible to diaagnose.

Hello and welcome to the forum :slight_smile:

So, which operating system are you using?
What is the size of your monitor?

If it’s Windows, you should find a crash log at -\AppData\Local\kritacrash.log.

That log is very long and should be made available by using a pastebin or by providing a link to a file sharing service or website.

I’ve just tried 5.0.0 compared with 4.4.8 and see no difference in size when 5.0.0 is set to 380px.
So, please check for any UI scaling setting changes anywhere.

Does the crash happen as soon as you activate the popup palette or when you try to use it?
If possible, a full screen screenshot when the popup palette is showing would be very useful to see. You can upload one in a reply here.

i use windows, and a monitor thats 7.7 to 13.5 inches

the crash happens as soon as i press the shortcut key before the pop up pallete shows up

Is that Windows 8, 10 or 11?

I was wondering about the size in pixels actually. So, what are they?

Are you using different monitors with one computer or an external monitor as an extended desktop? or whatever … ?

Is that error message image a Windows system level message?

Did you find ‘kritacrash.log’?

Are you saying that 4.4.8 does not crash and shows the popup palette with no problems if you use 4.4.8 on the same computer with the same small monitor?

-it is windows 10
-the screen resolution is 1366x768
-im using a singular laptop with no external monitor hooked up
-there is no windows system error message when krita crashes, it just crashes immediately
-yes i found ‘kritacrash.log’ and its the C++ exception handling exception at location 00007FF9920A4F69 in module KERNELBASE.dll


-yep, im saying that in 4.4.8 the pop up pallete wont crash krita and freely shows up for me to use it in the same laptop i use with the same monitor

Lots of relevant information so thank you :slight_smile:

Please make a formal bug report at: https://bugs.kde.org/
Sign up and sign in are needed.

You can (and should) attach kritacrash.log to the report.
For the Software/OS Versions section at the end of the report template, you can replace that template content with the output of Help → Show system information for bug reports.

Please put a link to the report in a reply here.

https://bugs.kde.org/show_bug.cgi?id=447868

1 Like

As an experiment, which should be harmless, can you try this:

Go to -\AppData\Local and find the file ‘kritarc’ which is the main configuration file.
With krita not running, edit it as follows:

Find the line that says ‘popuppalette/size=385’ (or whatever size it is) and change it to ‘popuppalette/size=280’
Save and Close then run krita to see if that helps.

(At a size of 280, the brush preset icons are almost useless but try it and see what happens.)

If you make any changes to popup palette options in krita settings after that, the popup palette size will be reset.

i have tried out editing the components in the file ‘kritarc’

i edited other components like recent files to see if it would be affected and it did, and changed the pop up palette size to 240 but still wouldnt load, freezes krita then crashes still.

The main problem is the C++ exception handling on the crash log which idk what it means and why the problem exists.

That’s actually your graphics driver crashing, nothing Krita can really do about.

And if Krita even tries to use OpenGL instead of ANGLE that probably means this is some super old integrated graphics that has no Direct3D 11 support, unless you had manually set graphics acceleration from “Auto” to “OpenGL”.

@Lynx3d Will you set the bug report to Upstream or Not A Bug?

We just noticed the crash originates from Small Color Selector docker (it uses OpenGL directly for HDR display support, similar to the canvas), so suggesting to disable canvas acceleration may not actually help.

You can try anyway, I’m not sure if hiding the Small Color Selector docker makes a difference, it will be loaded either way, just not rendered.

But aside of additional places where OpenGL code could be disabled, I’m afraid we really can’t do much to fix the issue.

I’m still not sure which CPU generation we’re talking about here, but it looks like the very first Core i generation with integrated graphics. The drivers haven’t been updated for close to a decade then, and Intel doesn’t mention Windows 10 support for that driver version either.

If you’re adventurous, you could try Linux…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.