Pressure&size- brushes

Hi Krita
I’m having a problem with the brushes. They don’t have these pointy/sharp edges. Mostly anything I do in the size doesn’t affect the brush at all.

I tried to report the problem but I still didn’t know-how. I looked at the guide on your website, I looked at other tutorials, I deleted Krita and redownload it but still. I tried drawing with a pen, my finger and mouse but still. so what do I do?

I’m using a laptop - Windows10 that has the touch & pen Feature. (though it would help clear the problem more)-

the same problem with all brushes

Not sure what you mean with sharp edges. I assume you want the srokes to change size as you put more or less pressure into it. This can only work with a tablet and pen that actually support pressure sensitivity, usually not doable with touch or mouse unless it’s the fancy equipment. So you probably need to check if your pen actually supports pressure otherwise it will only register two states (klick and no klick).

Here’s a repeat of a post I made some time ago:

There’s a basic test you can do to make sure that the stylus is sending good pressure signals to krita.

Go to Settings -> Configure Krita -> Tablet settings and click the large ‘Open Tablet Tester’ button. A ‘Tablet Tester’ window will open and you can drag it and resize it to make it conveniently large.
If you draw on the grid area on the left, you’ll see a log of the signals that krita sees on the right side.

Here’s what I get if I vary the pressure of my stylus while drawing:

The short blue line is what I drew and you can see on the right that my stylus was giving pressure in the range of 0% to 100%.
Those lines of text are produced very quickly and you’ll probably need to scroll the right hand side up and down to see them all.
You can click the Clear button and try again if there’s too much text in there.

Until you can see pressure in the range 0% to 100% in the tablet tester, there’s no point in trying to edit/design brush presets.

Also: In the image you uploaded, you’ve set Y-tilt to control the Size. Does your stylus have tilt sensitivity?


Thanks I’ll check the pen and confirm

like right? …still no changes

Your pen isn’t providing any pressure signals and is regarded as a mouse by krita.
If you’re using a touch sensitive laptop screen, this isn’t surprising because laptop screens would probably not be able to physically withstand the pressure required for ‘100%’ pressure, which can be quite high.
Unless you can find documentation or other information to the contrary, it looks like your pen/screen does not have presure sensitvity.

You can get good fairly cheap graphics tablets, especially those by Huion.
Wacom are very good but tend to be more expensive.

thanks for the advice.

Hi! I have just downloaded Krita today and experienced the same problems. I even used this post to try and solve my issues. I refused to believe that I’d have to go get a tablet. I have a surface pro 7, and this seemed to work for me.

I went into the tablet settings (which you were in before in the images you sent) and went under the heading ‘Tablet input API’ and changed it from ‘Wintab’ to 'Windows 8+ Pointer Input (Windows Ink). Then I closed and re opened Krita again. It seems to work for me now

I really hope this works for you!

1 Like

I was having the same problem and your reply totally fixed it! Thank you!

@melishka has a surface pro 7 with whatever specialist pen is appropriate for that.
Can you say which laptop and which pen you’re using?

I think we need a table showing which laptop and pen combinations are capable of giving pressure outputs.
The range of models is getting greater and their capabilities are getting more complicated every year.

@AhabGreybeard I’m not sure if you wanted my reply to what pen I use, but I will reply in case that this information is useful. I use the Microsoft Surface Pen Model 1776.

@melishka : I should have specifically asked you so thank you for saying what you have.