Random lines appear when drawing (Huion 1060plus)

Type of device* : Graphical tablet
Brand and version of the device: Huion 1060 plus
System** : MacOS Sierra

* graphics tablet/display tablet/2-in-1 laptop/Android tablet
** Windows/Linux/Mac/Android, + version (you’ll find it in Help -> Show system information for bug reports)


Description of the issue (you can include screenshots):
Hello,

I recently got a graphical tablet (Huion 1060 plus) and I just downloaded krita. For some reason, as soon as I start drawing something with the brush tool, some random lines keep appearing while I draw. After reading posts about other problems, I’ve played around with the pressure sensitivity and it’s doing better than with the default settings, but it still draws lines on its own from time to time… Before krita, I used this graphical tablet with photoshop in this same MacBook (it’s from 2011) and it didn’t show this problem.

Does anyone maybe have an idea of why this might be happening and how to solve it?

Thanks a lot in advanced! :slight_smile:

I see the same problems with our test Huion on my macbook pro in both Krita and in Corel Painter. I don’t have Photoshop on that system. I’ll ask my contacts at Huion what might be up.

1 Like

@boud, I would really appreciate that. Thanks a lot for the help!

Okay, I’ve heard back from Huion. Here’s their reply:

  • Random lines - there are several causes for this such as the driver or the pen. We would normally try to let the customers use their tablets without the driver. If the issue doesn’t appear without the driver, then they can just reinstall the driver. But if it’s still the same without the driver and even in other drawing programs aside from Krita, it is possible that the pen is broken.

  • Vague problems with press keys - our tablets’ press keys have been tested to work on moving the canvas in Krita. If the driver consistently show “Device connected” (see the lower left corner of the image in #3 below), then it is expected that the press key will work, unless it is a hardware problem.

  • ​Wintab vs Win Ink Protocol - our drivers are not always in Wintab protocol. When users enable the Windows Ink option in our driver, it uses the Windows Ink protocol. On the other hand, if it is disabled, it will use the Wintab protocol.

Sorry, I couldn’t answer before. I will definitely try those tips this weekend. I’ll keep you updated, I’ll post here if it worked out.

Thanks a lot for the help