Replacing the zoom and rotate cursor with new icons

The Icon for Pan Mode looks nice and crisp, but I find the icons for Rotate Mode and Zoom mode an eye-sore.

I use the Zoom Mode all the time, but I dislike the icon, it’s noisy and does not fit with the other nice looking icons. This icon alone makes Krita look more unpolished, and I can’t help it, but it annoys me more than it should.

Here is how they currently look:



In one of my setups, it’s so big too! It’s such a large piece of the UI, and I wish that it looked nice

I would love for it to be changed with new modern icons, that fit well with the other Krita Icons like Pan Mode!

I hadn’t noticed that until you mentioned it here. If you look at Pan, Colour Picker and the stepped Zoom (Ctrl+Alt+Space), they are all ‘good looking’ and I think that’s because they all use vertical/horizontal or 45 degree straight lines.

The continuous zoom and the rotate have curved lines which are always rough looking at small sizes. I suspect that the only way to have them looking ‘better’ would be to make them larger or have some redesign of their shapes.

That would be an interesting small project to try.

1 Like

I think it’s also that they seem like they are low resolution? Maybe they should be vector instead? :blush: On this pc they are quite large on a full HD screen, and still pixely and weird! They look bad on all my PCs/screens but especially this one!

I think it’s because of HighDPI settings. Some o fthe scaling looks really weird in some circumstances. For example I noticed that on my 4K screen with - I guess - 3x UI scaling for Krita I get super nice looking .kra thumbnails in the Recent Documents section on the Welcome Screen and super ugly and pixelated .png thumbnails (of the same images with the same size etc.). I’m gonna report this but I somehow never got a chance.

@Rakurri check if you don’t have enabled HighDPI; if so, disable it, on fullHD it shouldn’t be needed…

1 Like

Yeah, you’re right! When I turn off Hi-DPI it looks a bit nicer! Though the Pan Tool still looks better, as if it was in a more modern style. But sadly on my main screen, the Krita UI becomes way too small!

The reason I have Hi-DPI on is that right now I am working on my Wacom tablet (Full HD) connected to my Surface. The Surface has a resolution of 2736 x 1824 and I need to have Hi-DPI on most of the time since most often draw straight on the surface screen. So it’s best for me to have it turned on.

Same goes with my desktop setup which I use the most. My Wacom tablet is Full HD, but my main monitor is higher resolution, and I don’t want to keep turning the setting on and off depending on what screen I use Krita on.

Thank you for reporting this! I hope this can be fixed in the future!:grin:

1 Like