Rotation/Zoom Problems (Touching screen not working)

Type of device* : Laptop
Brand and version of the device: Microsoft Surface Pro 6
System** : Windows


Description of the issue (you can include screenshots): I can not rotate or zoom the canvas with my fingers for Krita. I checked the enable touch rotation and it is on. I think I might have clicked something that locked the canvas from rotating and zooming (maybe a key or something) and I don’t know how to fix it. I already tried uninstalling the app and removing all data and that still didn’t work either. Also, is there someone I can email directly/contact for this problem because it has happened numerous of times. I can usually fix it by uninstalling it, but this time that didn’t work.

I’m sorry, but I have no idea what might cause this: there is no way to lock rotation other than disabling touch rotation altogether.

Uninstalling and reinstalling Krita won’t change anything, ever.

And no, there’s no support email address: this is the right place to ask for help. Here your question may be read by someone who has experienced the problem. Krita’s isn’t made by a big company with a support deparment – we’re just a small band of free software enthousiasts doing our best.

What about the zooming issue with touch as well? I can’t pinch in or out to adjust the Canvas as well or does that fall into the same category as the rotation issue?

did this ever get solved? i’m having the same issue. when i try to pinch to zoom (i have a touchscreen monitor) it shows me a square with the color i’m using. idk if i clicked something by accident but it’s super annoying to not be able to pinch to adjust the canvas

Honestly, yes and no. For me the zoom and rotating started working out of nowhere. However, I have no clue on how it fixed, if it was the app or the computer’s fault, how to avoid this problem, etc. Keep in mind, I had this issue was on the app for months. I hope it doesn’t take you’re computer or app as long to fix this, but it just might. If anything, just keep your fingers crossed every time you open the app.

yeah, mine eventually fixed itself. my guess is it’s just a bug.

Zoom/panning issues

Hardware: WACOM MobileStudio Pro 16
Software: Krita 4.4.0, Windows 10

I am having issues with consistant zooming/panning using touch screen. On the previous version of krita I did not have any issues. The zoom will sometimes work with no panning, and other times it won’t zoom past a certain point. I have no issues with the touch screen any other time. Also I don’t have issues with the zoom or panning when I use them any other way. I believe my drivers are up to date but not completly sure. I was hoping it is an easy setting button or change. Please help! Should I just try to install a older version of Krita?

Hello and welcome to the forum :slight_smile:

I suggest that you remove your email address from this publicly viewable website because it’s an invitation for spammers (and worse) to send you emails.
Registered users here can contact you using a forum private message if they want to.

The only reason for using an older version of krita is if you’re using Windows 7 (which can no longer be supported).
Older versions have unfixed bugs in them, which are not good to have.
Note: The current formal release is version 4.4.2 so you should update to that. (This will be superceded by version 4.4.3 in the near future.)

As I understand the situation with Windows and Wacom, Windows now ‘takes care’ of Wacom driver installation and driver updates.
Windows based updates have ruined my Wacom driver more than once.

You could check the detailed settings in your Wacom control centre utility to see if anything settings are not right.
You should set up a separate profile for krita (while krita is running).
If you’ve previosuly done that then delete the existing krita profile, restart your computer, set up a new krita profile, restart your computer and see if that has fixed any problems.

I was having the same problems on my Windows Pro 7, but I found that my computer was in need of an update. Once I had updated my computer I had zero issues. I recommend finding out if your computer is need of an update before anything else!