Second Beta released for 4.4 (Help needed in Testing from Artists)

Published on Krita.org 2020-09-28T18:30:00Z

Thank you for helping us test the first beta. Today, we’re releasing Krita 4.4.0 beta 2: we found a number of regressions and release blocking bugs.

This beta has Android builds too, since we fixed many issues with accessing files on Android: however, because we now add translations the APK files are too big for the Play Store, and you will have to download them from download.kde.org

NOTE for Windows Users: Microsoft has changed the way applications signed with certificates are handled. Only Digicert certificates are automatically trusted, other certificates will only be trusted if enough people bypass smartscreen to run the signed application. Our builds are absolutely safe, so you can safely do that. If you see the “Windows protected your PC” screen, press “More Info”, then select “Run anyway”.

The full release notes bring you all the details!

Bugs fixed since beta 1

  • Disable the DDS file format.
  • Fix crash when loading a file with reference images (BUG:426839)
  • Fix lightness strength option for smudge engine (BUG:426874)
  • Fix Cutoff Pattern option BUG:426874
  • Android: Vector/references don’t get rendered (BUG:422312)
  • Fix updates of color picker’s preview (BUG:426867)
  • Windows: add .lnk files for starting Krita in minimal and animation mode
  • Fix crash when undoing Rectangle Selection and doing redo after
  • Fix a crash when moving local selection mask (BUG:426816)
  • Fix shortcut for Polygonal Selection Tool (BUG:426916)
  • Fix update of color preview in MyPaint Color Selector on mouse click
  • SeExpr: assert isDirty on the correct preset instance (BUG:426911)
  • Fix snapping decorations in Create Path Tool (BUG:426514)
  • Android: Use Storage Access Framework for all file operations (BUG:424541, BUG:423670)
  • Android: show recent files on Welcome widget
  • Android: Fix problem with loading/saving file layer
  • Android: Fix saving for files with no extension
  • Android: Fix saving with selections
  • Bugfix: usage logging could not be saved to a file on Android (BUG:427043)

Download

Windows

If you’re using the portable zip files, just open the zip file in Explorer and drag the folder somewhere convenient, then double-click on the krita icon in the folder. This will not impact an installed version of Krita, though it will share your settings and custom resources with your regular installed version of Krita. For reporting crashes, also get the debug symbols folder.

Linux

(If, for some reason, Firefox thinks it needs to load this as text: to download, right-click on the link.)

OSX

Note: the gmic-qt is not available on OSX.

Android/ChromeOS Beta

This time, the Android releases are made from the release tarball, so there are translations. We consider Krita on ChromeOS and Android still beta . There are many things that don’t work and other things that are impossible without a real keyboard.

Source code

md5sum

For all downloads:

Support Krita

Krita is a free and open source project. Please consider supporting the project with donations or by buying training videos! With your support, we can keep the core team working on Krita full-time.

5 Likes


Are you sure of your link? :thinking:

https://krita.org/en/shop/ seems better :slight_smile:

Grum999

Thanks for checking. I’ll inform about the website too. :+1:t4:

I killed Krita

Downloaded and ran 4.4 beta (appeimage) this morning. When Sessions dialog appeared i either pressed Delete or Close, I cannot remember which. Krita did not start. I went investigating with other versions on file - NONE of them would run! Oh oh.

Tried starting with the reset keys press - no joy.

Started 4.4.beta in a terminal session and I got this:
mugwah@mugwah-asus ~/app_images/krita_nightly $ ./krita-5.0.0.appimage
qt5ct: using qt5ct plugin
QSqlQuery::prepare: database not open
Could not prepare delete versioned resources from Unknown or Memory storages query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
Could not execute delete versioned resources from Unknown or Memory storages query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
QSqlQuery::prepare: database not open
Could not prepare delete resources from Unknown or Memory storages query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
Could not execute delete resources from Unknown or Memory storages query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
QSqlQuery::prepare: database not open
Could not prepare delete temporary versioned resources query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
Could not execute delete temporary versioned resources query. QSqlError("", “Driver not loaded”, “Driver not loaded”)
QSqlQuery::prepare: database not open
Could not prepare delete temporary resources query. QSqlError("", “Driver not loaded”, “Driver not loaded”)

I removed the files in .local/share but to no avail. No version of a krita appimage will run

I need expert help - please. Linux mint 19.3 tricia

That’s the version 5.0, not 4.4 ?

Grum999

Hello! I downloaded the Appimage of 4.4.0-beta2 on Kubuntu to try some SeExpr scripting. If want to type [ , ] or \ in the script editor, these don’t show up in the editor but trigger the shortcut in the main window. It does work fine in the Layer Properties window that shows up after the layer is created, though. It only happens if the window is opened again. Changing the shortcut fixes the issue.
Please let me know if you can confirm the issue before i report it.

Edit: Sorry i was unclear about the keys. They are:
[ (AltGr + 8)
] (AltGr + 9)
\ (AltGr + ß) (Might only be a ptoblem when Tool Options are in docker)

If I use ‘,’ or ‘\’ in the script editor, they work as ‘,’ or ‘\’ and do not trigger any shortcut action that I’ve assigned to them.

Maybe wait a while longer for feedback here. If it happens to you, consistently and repeatedly, then you should file a bug report.

1 Like

Yes you are correct - I tried all versions from terminal - that one was the most verbose.

This is the error from 4.4.1

qt5ct: using qt5ct plugin

Hope this gives you some insight as to what happened when I Pressed Del session

Thanks

Where did you load your appimage?

The appimage name you gave in example doesn’t match appimage name available on Krita website…

Concerning the error message, if problem occurs for ALL appimage you’ve downloaded (did you tried older appimage, like 4.3.0 or 4.2.9?), you might need to create a new topic because it’s seems to be not related to krita 4.4.0 beta2

The error message don’t talk to me, looking on Google there’s some “solution” about similar problem but as I’m not an expert too, don’t wan’t to give you wrong solution.

Let’s waiting for a developer answer.

Grum999

Thank you for your time. Yes all versions of Krita are now failing to run. The only thing I did prior to this happening was to delete an empty session. I don’t know the internal machinations of that but it did delete something critical that all versions of Krita appearantly needs!

I even installed 4.3.0 from PPA and it fails to run also.

Guess there is little option available to me except reinstall Mint - I need Krita working. Thankfully I have a (cough) Win 7 box running for emergencies such as these.

I will wait until morning for a “code saviour” to appear - then wipe SDD and reinstall! (sob)

Try removing the configuration in the .config folder (I don’t remember the name of krita’s files/folder inside). As Grum999 said, it’s better you post this in another thread or as a bug report because maybe something is wrong with session handling.

What, in particular, would you like us to test in this build?

Thanks for your suggestion. Panic over - I had a Timeshift (snapshot) so that saved me.
Is anyone is brave enough to press the Sessions Delete button when no sessions are saved?

Anyway enough excitement for one night,

Thanks to all
T

I’m not sure there’s particular things to test, usually use the beta like you usually do with a final release is already a good thing to check if everything is Ok in your workflow and usual tools you use.

Grum999

1 Like

Between beta2 and beta1 there were mostly fixes for Android, other than that small fixes here and there. Better focus on new functionality in beta1, which is Fill Layers (halftone filter, halftone patterns, SeExpr fill layers), new features in brush engine and others mentioned here https://krita.org/en/krita-4-4-0-release-notes/. I added a few fixes for Text Tool so it might be worth checking out (fix fancy fonts rendering, fix font options after clearing the rich text editor, fix ugliness text, I thought they were impacting users the most).

Also I just noticed that webm doesn’t work for me on Windows, could anyone else please check it out? (Especially with the new Gyan builds?) I can tell that it works just fine on Linux, so it’s probably lack of encoders.

1 Like

I’m noticing an issue with this version of Krita on the Surface Pro. It seems to randomly cut off input from the surface pen when trying to make a stroke. This didn’t happen in the previous version, I don’t think.

I’ll try re-installing krita later today and see if it’s working then.

Beyond that:

  • Fill layers and preview seem to render fine (windows version).
  • I’ve noticed that if you try to make the screentone fill have a large radius, that it starts to form artifacts and get very pixellated.

Loving the changes made to the fill layers UI! I’m going to read up on seExpr and start making some patterns :smiley:

Hi. Can you post a couple of pictures showing your parameters for the screentone generator as well as the resulting image with the artifacts?

Hello! I was making the image you had wanted, and I think I figured out what I was misunderstanding.

I left the post-processing options on default, including contrast which is default at 50%. This lead all of the dots having varied tones at the edges, which I incorrectly thought was a problem with resolution.

Going into post-processing and putting contrast to 100% gives you regular screentones with normal two-tones.

Apologies for the misunderstanding, I don’t think there’s a bug here. But I do think that contrast should be set to 100% by default because it gives the kind of sharp two-tone screentones that people are used to.

1 Like

I can also agree with setting the default to 100%, especially as I was also confused by this when first testing the feature. I would think most people with workflows featuring screentones would prefer pure duotone.

Also relating to the screentone generator, there is a minor inconsistency between the defaults of this Screentone Fill and the reworked Halftone Filter implemented in the nightly builds: While the Screentone Fill has a default rotation of 0 degrees, the reworked Halftone Filter has a default rotation of 45 degrees. Not sure if this is intentional, though it might be since the default rotation of the current Halftone Filter is also 45 degrees.