Tablet's not working properly.

Type of device : Graphics tablet
Brand and version of the device: Huion H610PRO V2
System : Windows 10 Home 20H2


Description of the issue: Hello. My tablet is not working with Krita properly. I can’t navigate trough the Krita’s interface with my tablet, I can only do this with mouse. When I am trying to navigate trough the Krita’s interface, the cursor is not moving and I can’t click anything. The only place where tablet is working is canvas. Also buttons on my tablet are not working with Krita. The tablet buttons have the shortcuts set correctly, but they still don’t work.

I will add one more little thing, because it’s also weird. In a driver for my tablet, there is a function to add an app to a list, so I could personalize some settings just for that chosen app and when I am trying to add Krita to that list, it also isn’t working. I am pressing “apply” after selecting the .exe file and Krita is not adding itself to app list in driver.

1 Like

Hello and welcome to the forum :slight_smile:

How long have you had that Huion tablet and how long have you been using krita?
Has it always had this problem?

It’s not that the selected application is supposed to add itself to the list.
The Huion setup/configuration utility is supposed to add the application to the list to make an application specific ‘profile’ for it.
As such, it sounds like the Huion utility and driver have a problem.

What happens if you try to make an application profile for GIMP, Blender, Inkscape etc?

Windows updates can mess with drivers and the 20H2 update was a big one.

I suggest that you get the latest driver from Huion and reinstall the driver.
Disconnect your tablet, restart the PC, uninstall the old driver, restart the PC, install the newer driver (or reinstall the existing one), restart the PC and then connect the tablet.

1 Like

I have this tablet for three months now and as far as I remember this problem was from the beginning of using my current tablet with Krita, so I’ve been using Krita also for three months (I know, it took long for me to finally write about this problem).

I was able to create profiles for Blender, Gimp or other applications and now after doing as you suggested, which was reinstalling the driver, I am also able to create profile for Krita. But unfortunately the bigger problem still exists.

I noticed another thing about it, that when I’m navigating through the canvas with tablet, two cursors are appearing. One is mouse cursor, which I can navigate through the interface with and the second, which is tablet’s one and it can’t go outside of the canvas area.

Did you look for a more recent driver from Huion?

I have no experience of Huion tablets so I don’t have any idea of what the setup/config utility can do.

If you haven’t got krita 4.4.2 then you should update to that before you do anything else. Updating to 4.4.2 won’t fix your problems (at least I assume it won’t) but you should always be using the latest version.

Have you tried Settings → Configure Krita → Tablet settings, where you can switch between Wintab and Windows Ink?
Make sure that Windows Ink is disabled in the Huion setup/config utility and also maybe at the Windows system level if you use Wintab in the krita settings. And of course make sure it’s enabled at the Windows and Huion end if you use Windows Ink in the krita settings.

At the Huion end there may be little things like ‘flicks’ and ‘gestures’ which it’s a good idea to turn off because it’s fancy stuff that can cause confusion and problems.

In fact, if there’s anything enabled that doesn’t sound lile ‘mainline’ functionality, turn it off to see if it’s been causing problems.

The Huion H610PRO V2 isn’t a rare tablet and if it wasn’t capable of working with krita then there would have been lots of people complaining about it before. I’m not aware of this being the case.
Also, if you look in the manual in the ‘Supported Tablets’ list:
The List of Supported Tablets — Krita Manual 4.4.0 documentation
every Huion tablet there is reported to work and it’s highly unlikely that Huion would have made one that doesn’t.

I read that Huion people work with krita developers so if you contact Huion then they may be able to offer more and better advice about this problem.

1 Like

Well. I see Huion H610PRO on the list of supported tablets, but not V2. So I guess no Krita for me.

I don’t think your conclusion is reasonable or logically justified.
If a tablet is on that list then it means that a krita developer has tried it and noted that it works or a krita user has reported that it works.
So far, nobody has said anything bad about your tablet, according to the list.
Did you try any of the things I suggested in my previous post?
Whatever you decide to do, good luck with it.

1 Like

I will try.

It worked. Thank you very much for help. :smile:

Oh good :slight_smile:
For future reference, and to maybe help someone else if they have problems, what did you do to get it working?

Disabled Windows Ink in my tablet’s driver and in Windows settings under Personalization → Taskbar → Turn system icons on or off → and then I found “Windows Ink Workspace” and switched it to “off”.

That probably means that the krita settings had Wintab enabled.
If you go to the krita settings and change that to Windows Ink and then undo those particular changes you made at the Windows+Huion end, it may work ok and also give you back the Windows Ink stuff in Windows.
For the moment, I suspect that you don’t want to do any more messing about with settings.

I had windows ink turned on in Krita, tablet driver and windows setting, but it wasn’t working. So in my case Krita is working only with windows ink disabled. But it’s nothing that I can’t use windows ink. This mode was made mainly for display tablets and using this mode with normal graphics tablet wasn’t that comfortable.

Tablet problems can be strange. Relax and use it now it’s working.

I need to update this fix a bit. I didn’t check it, but maybe turning off the windows ink wasn’t necessary. There is a button in Huion H610PRO v2 driver with a text “administrative privileges” and you need to click it and give driver those privileges. This was probably the only reason why tablet didn’t worked properly in Krita, because Krita needs administrative privileges and I guess that drives without them can’t work with app that have it.

I’ll ping @tiar about this because it all sounds unusual.

Don’t do this. It was my bad memory. In the past I tried to fix performance problems and for some reason I tried turning on “run as administrator” in Krita.exe properties → compatibility. So probably, because of my bad memory, I had all of this problem that caused in making this topic here. So I probably need to apologize to you for taking your time.

So everything is fine now?

I think lessons have been learned.

It all shows how many things can prevent the ‘simple’ task of connecting and using a graphics tablet. In addition to all the other things that are known and have been experienced over a long time.

I’ll update my metal checklist of questions to ask.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.