Trying to use Krita with an iPad on PC

Hi everyone,

I’ve recently purchased an iPad and an Apple Pencil and was amazed to find out about an app called EasyCanvas for it, which allows me to connect my iPad to my PC via USB and use it as a regular drawing tablet.

At first, I thought that it’s impossible to get pen pressure in Krita by using the iPad with EasyCanvas, but a bit of research has led me to learn that I had to switch Krita to work with Windows Ink instead of WinTab to get pen pressure to work.

Now another issue has risen:
For some reason, Krita doesn’t register every time the pen touches the screen. If I only made broad strokes, it wouldn’t be that much of an issue as I’d just try multiple times for each stroke, but I’d very much like to be able to sketch or do hatching and the such and without every stroke being registered, the results wouldn’t be very good.

This is an issue I haven’t run into when using a Wacom tablet nor when using the iPad to draw in other Windows programs.

Has anyone else on this forum ever tried using an iPad with EasyCanvas with Krita and has anyone else run into similar issues when switching to Windows Ink?

1 Like

I just got this as well and am having the same issue so it’s not just you. I haven’t found a fix yet unfortunately.

Krita actually doesn’t interface directly with tablets. We use (and have improved) Qt’s support for the Windows Ink and the Wintab api’s. If the EasyCanvas people have correctly implemented those api’s in their drivers, then Krita would work correctly. Please report a bug with EasyCanvas, (Maybe tell them Krita and Qt are open source so they can investigate how our code works so they can find the bug in their drivers…)

I have an exact similar problem. And it works slightly better after I tried to set "Windows 8+ Pointer Input)

Let me quote here:
" just go to Settings ‣ Configure Krita… ‣ Tablet Settings and toggle the Windows 8+ Pointer Input (Windows Ink) there. "
You can “Ctrl+F” then search 8+ on the original website for more detail info too, becoz i have no idea about the technical aspects of this: https://docs.krita.org/en/user_manual/drawing_tablets.html?highlight=tablet

Hello,

I have noticed a similar problem with another software to use iPad as a graphical tablet for Windows 10 (Astropad beta, aka “Project Blue”).

I pushed the investigation a bit further thanks to the “Tablet Tester” tool (available in Krita tablet settings) and there is a pattern: the stroke is registered only if a “mouse move” event is present between “stylus press” and “stylus release” events. Sometimes, the first “mouse move” event is present after the “stylus release” and the stroke is not registered. Issue frequency is about 5 to 10 strokes. See logs below.

The issue only occurs when “Windows 8+ Point Input (Windows Ink)” option is enabled. WinTab alternative does not offer pressure sensitivity.

Issue seems specific to Krita, other software like Blender and Microsoft Ink Whiteboard don’t suffer the same.

Logs of a missed stroke (Issue)

Pen tip brought near
Pen tip brought near
Stylus press X=62.98 Y=142.00 B=1 P=48.0%
Stylus move X=62.00 Y=144.00 B=1 P=48.2% (DRAW)
Stylus move X=62.00 Y=146.01 B=1 P=48.5% (DRAW)
Stylus move X=61.02 Y=146.99 B=1 P=48.9% (DRAW)
Stylus move X=61.02 Y=150.01 B=1 P=49.5% (DRAW)
Stylus move X=60.00 Y=152.02 B=1 P=50.1% (DRAW)
Mouse press X=63 Y=142 B=1
Stylus move X=60.00 Y=154.02 B=1 P=50.9% (DRAW)
Stylus move X=60.00 Y=155.98 B=1 P=51.9% (DRAW)
Stylus move X=60.00 Y=157.99 B=1 P=53.0% (DRAW)
Stylus move X=61.02 Y=159.99 B=1 P=54.3% (DRAW)
Stylus move X=62.00 Y=161.99 B=1 P=55.5% (DRAW)
Stylus move X=62.98 Y=163.01 B=1 P=56.6% (DRAW)
Stylus move X=64.99 Y=165.02 B=1 P=57.8% (DRAW)
Stylus move X=66.99 Y=166.00 B=1 P=59.0% (DRAW)
Stylus move X=68.99 Y=166.98 B=1 P=60.0% (DRAW)
Stylus move X=72.02 Y=166.98 B=1 P=60.8% (DRAW)
Stylus move X=75.00 Y=166.98 B=1 P=61.6% (DRAW)
Stylus move X=79.01 Y=166.00 B=1 P=61.7% (DRAW)
Stylus move X=83.01 Y=165.02 B=1 P=61.5% (DRAW)
Stylus move X=86.00 Y=164.00 B=1 P=61.3% (DRAW)
Stylus move X=90.01 Y=163.01 B=1 P=61.0% (DRAW)
Stylus move X=92.99 Y=161.99 B=1 P=55.7% (DRAW)
Stylus release X=92.99 Y=161.99 B=0 P=55.7%
Pen tip taken away
Mouse move X=93 Y=162 B=1
Mouse release

Logs of a registered stroke (OK)

Pen tip brought near
Stylus press X=50.99 Y=106.99 B=1 P=31.6%
Stylus move X=50.99 Y=106.99 B=1 P=31.7% (DRAW)
Stylus move X=50.99 Y=108.01 B=1 P=31.9% (DRAW)
Stylus move X=50.01 Y=108.01 B=1 P=32.3% (DRAW)
Stylus move X=50.01 Y=108.99 B=1 P=32.7% (DRAW)
Mouse press X=51 Y=107 B=1
Mouse move X=51 Y=107 B=1
Stylus move X=50.01 Y=110.01 B=1 P=33.2% (DRAW)
Stylus move X=50.01 Y=110.99 B=1 P=33.9% (DRAW)
Stylus move X=50.01 Y=113.00 B=1 P=34.6% (DRAW)
Stylus move X=48.99 Y=114.02 B=1 P=35.4% (DRAW)
Stylus move X=48.99 Y=115.98 B=1 P=36.1% (DRAW)
Stylus move X=48.99 Y=117.99 B=1 P=37.1% (DRAW)
Stylus move X=48.99 Y=121.01 B=1 P=38.2% (DRAW)
Stylus move X=50.01 Y=121.99 B=1 P=39.3% (DRAW)
Stylus move X=50.99 Y=125.02 B=1 P=40.3% (DRAW)
Stylus move X=52.01 Y=126.00 B=1 P=41.2% (DRAW)
Stylus move X=52.99 Y=128.00 B=1 P=42.1% (DRAW)
Stylus move X=55.00 Y=128.98 B=1 P=43.1% (DRAW)
Stylus move X=57.98 Y=130.99 B=1 P=43.8% (DRAW)
Stylus move X=59.99 Y=130.99 B=1 P=44.6% (DRAW)
Stylus move X=63.01 Y=132.01 B=1 P=45.4% (DRAW)
Stylus move X=66.00 Y=132.01 B=1 P=46.2% (DRAW)
Stylus move X=68.98 Y=132.01 B=1 P=46.3% (DRAW)
Stylus move X=72.01 Y=132.01 B=1 P=46.0% (DRAW)
Stylus move X=76.01 Y=130.99 B=1 P=45.6% (DRAW)
Stylus move X=78.01 Y=130.99 B=1 P=41.7% (DRAW)
Stylus release X=78.01 Y=130.99 B=0 P=41.7%
Pen tip taken away
Mouse move X=78 Y=131 B=1
Mouse release

I tried all workarounds I could find, none helped.
Is there something you can do on Krita side ? :slight_smile:

Thank you,
Damien

No, nothing, because, yes, even if it works in some other application, it’s a driver issue. Contact the developers of the driver about it. It’s their bug. Krita doesn’t even contain any code whatsoever that interfaces directly with the driver.

Hey Damien, I have the exact same issue as you. Every other stroke isn’t registered in Krita. Can’t find info on this anywhere else and I know it was already said there’s nothing to be done on Krita side. So by any chance did you find a solution to this by now?^^