GMI'C filters errors

I’ve used these thousands of times. All of sudden I’m getting errors:
*** Error in ./fx_spherize/spherize/*repeat/*local/ *** Command ‘input’: Unrecognized item ‘0°’ in expression ‘…rotf = rot(0°)…’.

*** Error in ./fx_tree/_fx_tree/*local/ *** Command ‘input’: Unrecognized item ‘0°’ in expression ‘…R = rot(0°)…’.

It seems related to “angle”. No matter what you change the angle to, you get the error:

*** Error in ./fx_tree/_fx_tree/*local/ *** Command ‘input’: Unrecognized item ‘38.7°’ in expression ‘…R = rot(38.7°)…’.

I uninstalled and reinstalled. Same issue. Also installed on a computer that never had Krita, same problem. Both Windows 64 systems. One Vista and one Windows 10. Anyone else? Try the “tree” filter under Rendering. Thanks!

:slight_smile: Hello and welcome to the forum @ejimarubr!

I’m not familiar with the Gmic plugin, but would have a few questions. What version of Krita are you using, current is 4.4.5?
Vista is no longer supported by current Krita versions (officially), if it still runs there it’s probably coincidence, or an ancient version.
Uninstalling Krita and reinstalling it does nothing.
Has Windows updated recently?
Since you seem to have installed Krita via installer, could you please download the portable version of Krita, and try if it works with that?

And I don’t see why we should try some “tree” filter, that won’t help us to solve your problem without an exact problem description! Please!
Besides, it works great for me! I can change the angles to whatever I want.

Please! Tree in Gmic!


Please! Result in Krita!

Helps nothing, shows only that it will work on proper configured systems!

However, I might not be able to answer more in-depth questions about Gmic, as I am not a Gmic expert!

Michelist

1 Like

Hello all,

On my end I see this problem too, I’m using Linux Pop OS and krita 4.4.3(Because the flatpak didn’t updated to this day). It seems to be a problem with GMI’C, although mine it is updated (using Krita’s GMI’C dialog box).

Symmetric 2D Shape and Thorn Fractal - Secant Sea also appears broken to me, but with different errors of course.

Thanks Daishishi. You are experiencing exactly what I am. I am 4.4.5 on Windows 10. I just installed 4.4.5 on an old Windows 7 computer and have the same problems. It has been offline for months. Must be something with the GMIC.

If you hit the “apply” button in the bottom right after it fails, you will see the same error I pasted.

It is strange @Michelist don’t experience any of those issues. @Michelist, are you using GMI’C version 2.9.6 (as shown on top of my screenshot)?

Maybe your GMI’C is a version older still? Or somehow a newer one?

I’m using 2.9.6 as you can see on my screenshots on a Windows 10 machine, perhaps I’m on another Build-Version of Windows?
I can’t find Thorn Fractal - Secant Sea in my Gmic, but with Symmetric 2D Shape there are also no problems.

Thorn Fractal in Gmic

Thorn Fractal in Krita

Michelist

I have tracked down the problem. The problem is Gmic update, I have, because of your question about the topicality of my version in Gmic hit the update button and already I also have this problem.
Now it is a matter of finding a solution… :upside_down_face:

Michelist

Thanks for replying, I didn’t see the version on top of your screenshot. My brain unconsciously filtered out the purple bar on the top. :rofl:

My suspicion is a problem with GMI’C version, but why you don’t see any problem it is a mystery. I really doubt it is a Krita or OS problem, because:

  • I tested with Krita 4.4.3 using the flatpak release, so the programs run in a sandbox-like environment. Which means Krita is installed with the right dependencies and independent from the ones installed under the OS (As far as I understand).
  • I also tested Krita 5.0 Alpha using a ppa. This means the config and resources folder from a ppa are independent from the flatpak install. As the Krita version is newer.

I tested GMI’C (version 2.9.7) using GIMP and had no problem whatsoever, see screeshots bellow.



Have blocked Gmic from internet access and deleted the Gmic folder in the user directory, on Windows it is the same folder where the Krita resource directory is, on Linux I have not tried this yet.
Since Krita restores Gmic on startup, it is an easy fix to do - as long as you are not afraid of your file system or even directories locked by the operating system by default.

Michelist

Use AppImage. The Flatpak from the flathub repo is not maintained by the Krita team it will update when the flathub devs update it.

I was wondering why some filters just stopped working for some reason, even when it was working perfectly fine some days ago. Can confirm the Simulate film and Color presets filters are also broken. I’ll try to install a new version and see how it works

For Color presets/Simulate film only the [collage] option is broken, if you select any other option it works

EDIT: I downloaded the latest GMIC version (not stable but latest dev option) , replaced the Gmic integration path with the new version and it works! Im on a windows machine and all the filters that were broken are working again (Tree, Simulate film and Color presets)

How do you download the latest GMIC version?

I figured out how to download it and execute the file but how does it get into Krita?

You need to make sure you got the version for Krita, its a zip file (you have to unzip it) then you open Krita, go to the setting and scroll to the bottom, you’ll see a category called “GMIC integration”.

You will see the file path, you need to change it to the location of the new version you downloaded (make sure you select the .exe file otherwise if you select just the folder it will not work)

1 Like

It worked!!! Thank you SO much!!

Is it normal that the setting to set gmic isn’t available in Krita nightly?

image

I ran in the same problem, probably with an update on gmic or something, I got the zip version from the official website, but I can’t set it anywhere in Krita v5.

Krita 5 has GMIC as internal inbuilt plugin so there is no need to install it separately.

O no, that means I can’t update it manually? So I’m stuck with the errors?! E.g.