Layer Style Effects Falls Under Background

Hello, I’m having a problem with Layer Styles. This is the first time I’ve used this feature and when I try to add effects, it falls under the background layer and I can’t see the effect unless I make the background layer invisible. How can I put the effects on top of the background layer, preferably on the actual layer itself?
There are a speech bubble and a random shape on the pictures and as you can see the effects are not visible. (I’m using Krita 5 btw)

Thank you in advance.


Hello and welcome to the forum :slight_smile:

What is the complete version number?
Which operating system are you using?
Which layer style(s) are you using?

Can you upload a screenshot of the Layer Style window?

Edit:Add: Why isn’t that white shape showing on the layer thumbnail in the layers docker?

I’m using Windows 10 and Krita x64-5.0.6.
I used the drop shadow, but any other layer style is not showing up either.
Here are the screenshots (I actually didn’t save the previous one but I created a similar example, in the last example I drew both shapes in the same layer, now I used two separate layers)



Thank you for the answer.

With the same layer style and same settings as you, I don’t have a problem:

You don’t show a screenshot of the problem with the background layer visible.

The only way I can get a similar problem to the one you initially posted is if I set the layer style blending mode to Subtract instead of Multiply.

If you still have this problem, can you make the .kra file available by providing a link to a file sharing service or website>?

Here is the link, I’m still having the same problem unfortunately:’((

I should have looked more closely at the status bar of your later images.
(I should have asked to see the status bar from your first images.)
You are using a CMYK/A colour space. The blending modes behave differently with CMYK/A images.

I converted the document to RGB/A by using Image → Convert Image Colour Space:

The status bar now shows it to be RGB/A and layers styles work as expected.

You should always work with RGB/A 8-bit integer default, unless you have a good and well understood reason for using any other colour space.

Thank you so much for your help, I changed it and finally it works!! :sob:

1 Like

As a side note, are you aware that krita has vector libraries and there is a collection of speech bubbles that you can use?
You drag them out of the Vector Libraries docker onto a Vector Layer, then you can move and resize them as you wish.
Here they are with layer style set to Drop Shadow and a thin Stroke:

You get the vector Libraries docker by Settings → Dockers → Vector Libraries:

You need speech bubbles? Maybe the plugin “Rogudator’s Speech Bubble Generator” would be interesting for you. There you can compose different speech bubbles with a click of a button, enter the desired text and then have the speech bubble generated.

Michelist

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.