Lot Of Problems With Krita T_T

WARNING : Lot of anger coming

Before everything, here’s my infos :

-My computer is a Windows 10 Home (Lenovo)
-I’m using the Wacom One tablet (Not One By Wacom!)
-I installed Krita 4.4.7 (Latest version I hope) with all the system requirements : PC 64bit, lot of space, 8GB RAM and it works perfectly!

Basically, Krita wants me to take my computer and throw it out of the window lol.

  1. It’s lagging a FREAKIN MUCH. Wich is REALLY frustrating with a fast workflow like mine…
    When I start Krita, it keeps taking more than 30 seconds to finally open up. (I don’t know if it’s normal. All other programs I tried weren’t taking so much time…)
    Clicking on ANYTHING takes more than 15 seconds. EVEN CLOSING THE PROGRAM TAKES SO MUCH TIME! (Like for opening Krita, don’t know if it’s normal)
    When I draw, the lines start after a certain time to lag and having big delays.

  2. When it doesn’t lag too much, stupid weird white lines keep apearing when I move my pen. It doesn’t really affect anything but it’s SOOOO frustrating. Don’t know how to explain it, let’s say the circle is my pen who moved from right side to left side and the lines are what’s happening :

                  ○ ||||||||||||||||||||| | | |          <-------
    
  3. Sometimes, Krita is opening not well installed. Like, buttons are not correctly placed, I can’t see all options and things like that. I have to restart the program after…

I tried to desable the OI or OG thing (Edit : I meant OpenGL lol) and changed the scaling option (Edit : Looks like I didn’t in reality :/) but EVERYTHING continues! I also close all other apps and things who could cause the problems. BUT IT STILL CONTINUES! My computer isn’t the problem, it’s really fast when I’m not using Krita. And I got it not a long time ago, there’s almost nothing in it!

Also something else frustrating but could just ignore :
I can’t undo really far away. Wondering if there’s a way to undo farter than what we can normally do… Tried to change the swap undo thing even if I’m not sure of what it does but nothing really changed. It really trigers me but it’s ok if there’s no solution…

Thank you so much for listening to me even if you don’t know what to do. Really had to empty that anger, I’ve no one else to talk to lol. And thank you 2000x more if you can resolve at least one of my issues! :slight_smile: I really love Krita (when it works a bit) and I tried a lot of other programs but I prefer Krita the most…

Have a great day/night!

Yeah, it doesn’t sound normal at all. Have you tried switching the Renderer in Configure Krita → Display? After that, you need to restart Krita.

2 Likes

When you’re laptop has 8 GB RAM built in and you run Windows 10 on it you will most likely have less then 4 GB remaining for other software and even less for Krita. Not so much of a problem when you have small drawings but for big projects you are going to hit your laptop’s limits quickly. However for now you seem to have other issues.

1 Like

You can increase the undo steps in the Krita settings to a maximum of thousand

But every undo step will take up a bit of RAM until it hits the limit at which either the RAM is full or the swap limit is reached (the thing you configured). At that point Krita will swap i.e. writing RAM to the hard drive and Krita will get really slow because hard drives are simply much slower than RAM. Same goes for the actual image data. If Krita runs out of memory, it will swap RAM content to the disk and get slow.

So while you can have up to 1000 undo steps in theory, there is also a limit set by your laptops RAM.

Maybe you should check in the task manager how much of your RAM is actually free before and after you start krita. I suspect half of it is already taken before Krita even starts.

What CPU does your laptop have and what’s its load? Most laptops are not really equiped with decent CPUs since most of them are not build for heavy work (which digital art usually is).

1 Like

Sorry for responding only NOW, should have checked replies earlier lol.

So, for some reason, Krita decided to become much smaller than usual. I don’t know why, I did nothing :confused:

The weird lines seem to be gone because of it. And Krita is now well installing I think.That’s 2 less issues I guess… But it’s still pretty slow.

For Tiar : It’s saying that my current renderer is OpenGL and I can’t change it.
But also says that my preferred renderer was Auto Direct3D 11 via ANGLE. I tried changing it to OpenGL and it seems to work better… But still starts to lag and delay a lot after a certain time. Wich renderer should I use? OpenGL or maybe the Software Renderer (It says “very slow” but who knows…) Maybe staying to Direct3D will work too but I’ll of course have to change other settings…

For Takiro : I went to the task manager and not sure of where was the RAM usage (I’m not even sure what’s a RAM lmao) but here’s what I saw :

-Before starting Krita, 61% of my memory was used. Wich was 4.9 GB out of 7.6. (I think the rest of the 8GB is used for hardware or something.) Don’t really know if it’s a lot lot…

-After starting Krita, 65% of my memory was used. Still 4.9 GB out of 7.6. Sometimes it was going to 5GB.
I tried to push Krita to undo until it reaches the RAM limit and drew until the lines lag but nothing changed in the task manager.
It also says that Krita is using 393.9MB of my memory.

I couldn’t find the CPU of my computer, it was really hard to find/tell… I’ll try again after writing the reply.

4 more things :

-I’m using 1280x1280 canevas and I’m planing to do art on Instagram. Are they too big for Krita?
-It says in Krita’s display settings that the scalling mode is High Quality Filtering. Is it also causing lag and slower? If yes, I should change it to what? Nearest Neighbour, Billenar Filtering or Trillenar Filtering?
-If I increase the undo steps, will Krita slow down much more considering the amount of memory it and my computer uses?
-What more should I do for making Krita faster?

Thank you so much for helping me, I’m so happy! Hopefully Krita can work soon with your help! :heart:

Yes, it does make it slower. The performance is as follows (from the most “expensive”, which means slowest):

  • high filtering
  • trilinear
  • bilinear
  • nearest neighbour (which is pretty ugly)
    However a standard, even low-end laptop graphics card should be able to use high quality with not much issue.

What do you mean by “I can’t change it”?
For the Renderer, use the one you feel is better. It sometimes depends on your graphics driver.

Talking about the graphics driver, make sure to update your graphics/GPU driver. Bad driver can cause slowdown there.

1024x1024 canvas is quite small, so you really shouldn’t see any annoying slowdown, unless you’re trying to paint on a toaster or other household device :wink: Which often means there is some problem with drivers.

Can you please copy Help → Show system information for bug reports and share it here? And then please switch the Renderer to the other one (remember to restart Krita) and copy it and share that one too. (It will tell us your CPU too, I think).

1 Like

(Sorry for the time)

(P.S. When I wrote “slower”, I meant slowness sorry XD)

So, I said “I can’t change it” but after switching to OpenGL, I saw that it was actually changing it :confused: My bad lol. I tried Krita after changing the renderer to OpenGL, the scalling mode and my normal used canevas size but nothing truly changed. I searched for updating my graphics/GPU driver and I think it is up to date. I’m not sure, I searched in Device Manager and everything’s apparently up to date. And here are the photos
(I couldn’t log in from my computer so I had to take the photos with my phone. Sorry for the bad quality)


(I have to do a second reply for putting the third photo, wait a minute please)

Here’s the third photo :

Can you see how much ram krita has in the performance settings of krita

1 Like

It looks like you’re running Windows Vista with onboard Intel graphics.
Krita doesn’t even supporrt Windows 7 anymore.

3 Likes

Bingo. :slight_smile: :slight_smile:

1 Like

WAIT, how I’m running Windows Vista with onboard Intel Graphics??? I’m on Windows 10! (Sorry for my confusion, I don’t a lot lot about computers ;-; ) How do I change that??? D:

And it says in the performance settings “Memory Available : 7,739 MiB” and “Memory Limit : 3869 MiB”.

(Thanks a lot guys, I think we’re close of something)

Assuming that I can read properly from the photo you took of the system information listing:

“Kernel Version: 6.0.6002
Pretty Productname: Windows 6.0”
etc.

Why do you think you’re running Windows 10?
How old is your computer?

Re. changing the graphics: Notice the warning in the third photo.

1 Like

Oops the warning…

I got it on July. July 29 precisly. It says in the Settings → System → About of my computer that the PC is edition Windows 10 Home… Nothing says 6.0 at all…
And I take a regulary look if there’s any update to do… In Windows Update, the Lenovo Vantage, even in Bitdefender…

I assume you mean this year. Did you buy it new from a shop in retail packaging?

Lenovo Vantage is an application/utility from Lenovo that ‘manages’ your computer and keeps it up to date etc, or so it’s claimed.

I’ve no idea why krita would report the PC as being Windows 6.0 if it’s really Windows 10 but someone who knows more about this area may have an idea.

The simple fact is that all over the word, thousands of people run and use krita with no problem on a variety of different computers and a number of different tablets when running Windows 10. There must be something strange about your computer.

If it has 8GB of RAM and krita has 4GB allocated (that’s 50%, the default allocation), it should start and run with no problems.

I have a ten year old desktop that’s almost falling apart and krita runs fine on that with Windows 10.

If you do a full power down restart, what does the Windows Task Manager say about the amount of RAM used and the applications using it?
If you then run krita, what does Task Manager say about its RAM usage?

1 Like

Yea I bought it new from a shop and all other things you said.

So, I restarted the computer and checked the task manager before running Krita.

Somethings changed from yesterday : At the begining, 65% of my memory was used by my apps but it quickly decreased to 57%. At the moment I’m writing this, it keeps going down. So 4.3 GB out of 7.6 is used. And the power usage of all my apps is very low. Sometimes, some are going to low and Bitdefender even to moderate but then everything return to low.

After running Krita, it returned to 65% of the memory. 5.0 GB out of 7.6. Very Low power usage the manager says.

I rechecked the system informations for bug reports but nothing changed. I’ll search help for that too.

For a freshly restarted Windows 10 PC, having 4.3GB RAM in use sounds high to me but I don’t have lots of background applications running, like maybe Lenovo Vantage and Bitdefender for example.

With krita running, if there’s 2.6GB free then there should be no problem making a small and simple image with quite a few layers.
Krita tells you how much RAM it’s using on the RAM meter on the status bar at the bottom.

Can you post a screenshot of your Task Manager while krita is running?

@tiar: The system info listing stopped giving CPU id some time ago. I don’t know why and I can’t remember when.

I’ve just noticed, your GPU Acceleration is ‘desktop’.

1 Like

Your Krita behaviour is weird and it shouldn’t be, at least not for lack of computer power or RAM. @AhabGreybeard mentioned Krita running on a 10 year old PC, I personally ran Krita on a 2013 PC until earlier this year (CPU AMD FX 8350).

Your PC also has really new parts in it, and maybe this is one of the problem (more about this bellow). Your System Report shows your GPU being an Intel Iris Xe, this is a Onboard graphic chip only available in 11th Gen CPUs. More specificly is a GPU present in i3, i5 or i7 launched this year. Here is the Intel page about the Iris Xe.
My last paragraph while tech-savvy is to say: Your CPU is powerful enough to run Krita, even if it is an i3. You didn’t hit the RAM limit to experience slow downs. So this leaves only one suspect, the GPU.

This is a new Graphic Card architecture by Intel, so they are experiencing some problems with drivers. Try using the Render in Krita as Software to see if the problems stop.
Also here is the Official Intel Page to update your drivers: Intel Auto-update
The updater is a program that will install, detect and update your Xe GPU driver.

1 Like

Here is the processe of Krita :

Here is the memory usage :

If I understand, I try changing the renderer to Software and I update the drivers… It’s safe uh?

Also, what does the GPU Acceleration do if it’s on Desktop? Is it bad?

I can’t remember, it’s ages since I had a look in that area.

For the suggestions by @Daishishi , trying the Renderer set to Software will give you a quick check/test to see if it’s the GPU that’s the problem. If it works ok (but maybe slowly) with Software rendering then it’s the GPU that’s the problem.

Then, you use that Intel utility to check and update the graphics driver and then set it back to OpenGL or Angle to use the GPU
That is safe, if you trust Intel to get it right, which sounds like a reasonable assumption.

2 Likes