Panning key input executes unintentionally although space bar isn't pressed

Krita for some reason executes the panning key input everytime it detects my pen.
Causing my canvas to do nothing but pan, and pan, and pan. I have no idea how exactly to stop this issue which happens at random. But it really pisses off when it occurs.
What’s happening there ?

If it were my keyboard, I would have to re-engage or re-bend the return spring as it is old and worn out. Have you tried another keyboard to rule out your keyboard as the cause?
If it’s a wireless keyboard, I would check the battery or move the transmitter and receiver closer together.
If these are not the causes, Krita must be getting this keyboard event reported from somewhere, and this culprit needs to be found.
There are probably more possible causes, so if you have any ideas, please share them here!
I keep my fingers crossed that you will find a solution quickly.

Michelist

Could also be a pen issue because when I keep the side button on my pen pressed (which is mapped to middle mouse button) I get the same behavior you describe, just as if your pen’s side button is stuck.

1 Like

I guarantee that this issue has nothing to do with the pen button being pressed or even my keyboard.
Because, no single button is pressed when it happens.
Plus, I even changed my tablet to get a brand new one not so long ago.

Also none of my pen buttons is mapped to middle mouse click in the first place.
One is set for right click, the other for eraser switch.
Krita has a problem.

What does Krita’s tablet tester tool say?

pen tip brought near
pen tip taken away
pen tip brought near
pen tip taken away



And again, for some reason, I can’t seem to reproduce the bug…
It’s gone right now…

Usually, to temporarily get rid of the issue, I switch to another app, press right click, then go back to Krita before the issue stops.

This… is weird.

Check the tablet tester immediately when you encounter this again. I have seen this issue somewhere on reddit or here on forum. I don’t know how to diagnose this.

Behold. The issue started again, right after I opened the brush settings panel.

This is what the tablet input tester displays every time pen detection occurs :

Definitely something wrong with Krita. Because I’m not even touching the surface of the tablet, nor am I pressing on space bar.
When I press on space bar, it writes “HOVER” instead of “DRAW” at the end of each of these lines.

Yup I have this issue too and for a really long while.
Never reported b cause I can’t reproduce it.

The problem is the B=4 item. It should say B=1 for left-click equivalent.
B=4 is a middle-click equivalent and so you get panning.
You can confirm all that by using your mouse on the tablet tester.

When I press the spacebar it doesn’t say “HOVER” at any time, it always says “DRAW”.

What you see is what krita sees and that is coming from your tablet/driver/OS combination.

A Windows update could have affected your tablet driver, Have you tried reinstalling it?

I’d look at the tablet setup utility, delete and remake a new profile for krita, make sure the stylus tip settings were ok.
I’d also try Wintab and turn off Windows Ink at the tablet and OS level too, if possible.
If it’s already on Wintab, I’d try Windows Ink.

Windows update ?
This issue is very old you know.
Something is definitely wrong with Krita.
In Photoshop or Clip Studio, this pan issue never happens.
The tablet driver or OS has nothing to do with this problem. Krita is the reason.

this is a Krita thing sorry.

I come from 3D like blender and I pan around like crazy using modifier keys and the key gets locked into the wrong state. Krita sometimes just does not keep up and messes up the order internally.

It is not drivers if it was pressing the key again would not fix it I would have it reinstall to get it working again.

The thing is by the time you fix it you lost your brush settings. I made Tela with SOF settings in order to quickly load them back in again.

If it is caused by complicated timing/interaction of events and action, would that point to a Qt problem or an OS interaction problem?

Switching to another app would also change the tablet driver configuration (assuming it has the facility for multiple application profiles).

Once again, I don’t set multiple profiles for different applications from my tablet driver utility at all. I use a global one. But I say global, there’s no single profile set.
Plus, if your hypothesis was true, I wouldn’t even need to right click in another app before switching back to Krita for it to stop the panning problem. Unfortunately, if I don’t right click, the pan continues if I go back to Krita. Only the right click method works. That’s super weird.