Pen Pressure not working Desktop Levono yoga A940

Lenovo yoga A940 (desktop AMD Radeon RX 560X ): 16GB DDR4
Brand and version of the device:
System: Windows 10 Version 2004 for x64-based Systems (KB4565503)
Pen Pressure sensitivity “not working”
Hello thanks for read this
I’ve read other forum on this site and others
Followed the steps to repair this software but “no success”
Made adjustments on “configure Krita” and change to Windows 8-ink
Clicked “ok”
Rest the software and reopen the software and still “thinking my pen is a mouse” (no pressure sensitivity)
I also have Krita download on my Surface pro 6
Made the adjustments as I mentioned and runs great. “No problems”
Would like to run Krita on a larger screen “Levono yoga A940”

What can I do to fix this on my desktop?
Thanks for reading
Happy drawing.

I don’t have an answer for you, but I purchased a reconditioned Lenovo Yoga 260 specifically because of the stylus/touchscreen hoping to rekindle my digital art work/journey but found that the stylus and it’s usefulness with Krita and Corel Painter was pretty worthless compared to my Wacom drawing tablet. :frowning:

I have to some extent rekindled my digital art exploration, but will not be using the Lenovo stylus…I may or may not use the Lenovo for art, but if so will use the Wacom plugged into it.

Hope your journey is copacetic!

Thank you kacart for responding
and yes I totally agree with you Levono’s stylus pen is not the greatest pen to conduct art work.
Including there touch screen, seems not to register the difference between pen and your hand. (just seems its not even working) “like some cheep knock off brand”
thanks again for the response. Happy drawing!

Hi guys, I have similar issues with one tablet did you review your krita tablet configuration?


if you are using and stylus with windows 10 0r 8 you must activate this funtion on krita.
2. Also you cna figure out if you need to update your drivers specially if you are using w10 with the new release, to find out if are your drivers you must sear in to the services on windows and search for pen and tablet funtions and stop the service then restart the service if that works you should be able to work on Krita, but if you lose that configuration after a restart you really need to update your drivers and also the netframework

1 Like

Yes I tried adjusting that to no avail on the Lenovo touch screen.

So it’s really weird. After messing with Krita for 3 hours trying to get the pen pressure to work, you have to initiate the windows 8+ pointer input that Nayo posted and then at the bottom right of your screen (in your taskbar next to the time and date), click the notifications “action center” button (it looks like a message). A side bar will pop up, click the “tablet mode” button that’s towards the bottom of the screen and you should now be able to use your pen with pen pressure in krita. Getting the pen to function efficiently the entire time without it dropping off mid-stroke is a whole other demon I’m trying to battle. :roll_eyes:

Hopefully this helps. There’s little to no information out there for how to use the Yoga A940 with almost ANY application so there’s been quite a few headaches and growing pains with this computer.

1 Like

Hey y’all, was having the same issue with pen pressure not working at all! I was so annoyed. But I went to the wacom drivers website and just tried downloading their newest driver on their home page (Driver 6.3.40-2) for my operating system; it downloaded, restarted, and I opened krita to find my pen pressure working! Have no idea why it worked, but it did. Hopes this helps you guys!

The question/issue is not about Wacom but about the Lenovo screen and pen pressure…

Yoga’s use Wacom technology for the pen support, though.

I wasn’t aware that Lenovo incorporated actual wacom technology for their touchscreen. Even so I would think the driver/details are quite different.

In any case my experience with the Lenovo Pen and screen (on a Lenovo 260) for use with Krita/Painter particularly the pen pressure was atrocious.

In doing some googling, I do see this here with regard to the C930:

“Now the Lenovo Active Pen features 4096 pressure levels , supports Wacom AES technology and is included with some models”

but still…

There are wacom drivers for yoga’s, though: for example https://support.lenovo.com/nl/en/downloads/ds502477 – I’m not sure whether I installed those on my yoga 920 because right now it’s building Krita running Linux… But for my model, the pen has always worked really well, both in windows and Linux.

When someone just relies on system when they have a Yoga, that means they’re most probably using Windows Ink and they need to switch Krita to use it, too.

When someone downloads and installs a Wacom driver, then by default Wintab is enabled too and they could use the Wintab API (which is default in Krita). Sometimes there is some error when both Wintab and Windows Ink is enabled in the tablet driver, I don’t think it happens with Wacoms but it does happen with Huion and XP Pens - then you might need to either switch Krita to Windows Ink or disable Windows Ink in the driver.

Thank you for the link, I’ll give it a shot.